PDA

View Full Version : Timeout too fast in NetworkManager for Fedora 14?



greg.harvey
8th March 2011, 09:44 AM
Hi,

I seem to be having this problem with Fedora 14:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/292054

My wireless device is an Intel Ultimate N WiFi Link 5300, driver is iwl4965. Post-suspend I see exactly the same messages as in that Ubuntu report. Restarting NM does not help.

Anyone seen this? Is there a way to lengthen to timeout or kick the device in to life some other way?

stoat
8th March 2011, 02:15 PM
Post-suspend I see exactly the same messages as in that Ubuntu report.If this is happening upon resuming from suspend, and it works fine before suspending, then try this experiment. Repeat whatever you do to make it happen and then remove the wireless driver module with modprobe. Then immediately reload the wireless module with modprobe. Give NetworkManager several seconds to react.

If that experiment worked to re-establish the connection, then it is a common issue and probably can be fixed with a pm-utils script in /etc/pm/sleep.d. Stopping here now in case it doesn't work. Details available though, if needed.

P.S.: Are you sure about that iwl4965 driver module for that chipset? Could be, I just thought it used iwlagn. Whatever works. Anyway, check the module to remove for the experiment with these...
lsmod | sort
lspci -k

greg.harvey
9th March 2011, 11:41 PM
Your theory sounds reasonable, but I can't get my computer to do it again now! It was doing it consistently last week at my in-laws place, but now it's behaving perfectly back home. Next time I see this behaviour I'll try this and report back.

Re: the driver, that's just what what I read - I can't remember where. Maybe from yum? When I do lsmod I get iwlagn, so that's the driver I guess.

greg.harvey
13th March 2011, 11:51 PM
Ok, finally got it to do it again! Problem seems intermittent, but your fix worked perfectly. Using modprobe to restart the driver (iwlagn) made everything return to normality without a reboot. Yay!

So, moving on, I assume any batch script in the /etc/pm/sleep.d directory gets run when the machine comes back from suspend? I'm guessing that based on your comments - so if I create a bash script in that directory that simply executes the two commands to disable and enable the driver that should fix this? :)

Edit: arrr! Every time I use "quick post" it double-posts my message. *sigh*

stoat
13th March 2011, 11:57 PM
Problem seems intermittent, but your fix worked perfectly


So, moving on, I assume any batch script in the /etc/pm/sleep.d directory gets run when the machine comes back from suspend?Check for pm-utils and install it if it's not installed...
rpm -q pm-utils
Use your favorite text editor to write a simple bash script like this example...
#!/bin/bash
case $1 in
hibernate)
/sbin/modprobe -r iwlagn
;;
suspend)
/sbin/modprobe -r iwlagn
;;
resume)
/sbin/modprobe iwlagn
;;
thaw)
/sbin/modprobe iwlagn
;;
esac
Save it as say 01wireless (or whatever) in the /etc/pm/sleep.d folder.

Make it executable...
su
chmod +x /etc/pm/sleep.d/01wirelessThat's it. Anyway, the successful test with modprobe is a good sign. And if the script doesn't work, no worries. It's harmless and reversible.

greg.harvey
14th March 2011, 09:55 AM
Great, I've followed these steps. If you don't hear back from me, you can assume this is resolved - I'll try to remember to come back in a few months and report everything is fine, but I might forget. ;-)