PDA

View Full Version : Can't Login



byw
1st November 2004, 06:50 PM
Hi

Quick Question!

When i start Fedora Core 2 up. Go through the normal startup, end up at the gui login screen. I then type my username and password in, a message comes up "Authentication Failed". I have tried this with three other users but only root will login.
Any Clues?

Thanks

MikeyMike
1st November 2004, 07:04 PM
u could try deletin those users and create new ones mite work

byw
1st November 2004, 07:19 PM
Unfortunately that didn’t work, still says that the “Authentication Failed”

bob
1st November 2004, 07:38 PM
I'd check the permissions on /bin/bash. They should look like this:
-rwxr-xr-x 1 root root
This allows only root to 'read,write,execute', while group and user can read, &xecute. That last 'x' may be a '-'

Quella
1st November 2004, 07:38 PM
If you can login as root, have you tried to change the passwords on one of these other accounts and login? Is this the only message? Have to tried to do it in a command windows and not in the GUI? Do these users have home directories assigned to them? How did you create the users, GUI or command? If command, what was the command you used to create them?

Quella

byw
1st November 2004, 08:04 PM
The /bin/bash is set to -rwxr-xr-x
Yes I have changed the passwords for the other accounts and they all have home directories assigned.
There is only one message which comes up "Authentication Failed"
I created the users in the GUI form as i found it easyier
How do I login using command prompt?

Thanks

theninja
1st November 2004, 08:55 PM
as root try to switch user to that user. like so.... su - "username"
Does that work?

Quella
1st November 2004, 08:56 PM
From the GUI switch to a text-based login by pressing <SHIFT> + <CTRL> + <ALT> and press one of the <Fx> keys from 1-6. So you could use <F1> and it would go to the fist text-based login. To get back to the GUI, use the same as above, but enter <F7>, or is it 8? Let us know what you get as output from this screen. It may provid more details. Not sure.

Quella.

kosmosik
1st November 2004, 09:04 PM
instead of trying some voodoo I suggest you try to look at GDM (that is login manager) log file and check out what caused bad auth (if it is not in GDM than it is lower, try /var/log/messages for login logs)...

byw
1st November 2004, 09:34 PM
The /var/log/messages came up with a problem with LDAP, so I have disabled it and the text based & gui login worked fine afterwards. I am still a llittle confused as to why LDAP caused the problem, but I will save that for another day.

Thanks all!