PDA

View Full Version : My ifconfig...



boomer ang
1st November 2004, 05:06 PM
Hi All,

I'm new here and almost a beginner even on Linux.

When from user account I run ifconfig command my Linux doesn't find it ( Fedora 2 updated ) therefore I switch to root but the result is the same. Therefore I look into sbin folder and I can spot the ifconfig command but it doesn't seem to exist as well when I try such command :mad:

I have to say that such command inside the sbin folder it's green colored. like many other... :confused: and they seem all to be there but unusable.... :mad:


I also have latest net tools.....

Do you have tricks for me ?

Thanks a lot in advance

Boomer

jayemef
1st November 2004, 05:11 PM
Well, I'm not really sure why you weren't able to get it to work under root. But not being able to as a normal user is normal. You aren't supposed to, for security reasons. As for the files that appear green, they are executable files.

Good luck with the problem...

boomer ang
1st November 2004, 05:15 PM
Yep... this is puzzling me....just when on root in my low knowledge everything must work.....

I have to say I have not yet your kernel cause it gave me dramatic problem on installation while I have the previous one and it is working fine...


Boomer

boomer ang
1st November 2004, 05:24 PM
This is funny to my rookie eyes ....


I have seen that :

If I log off from the system and login from scratch as root the ifconfig works, if I open a shell as user $ and switch with su to root # account with proper root psw ,well, it doesn't anymore :confused:

Is iit a bug or is it my knowledge that is soo poor ?


Thanks mates


Boomer

gablaxian
1st November 2004, 05:29 PM
yes, it is your lack of knowledge in this case.

If you want to access all of roots commands while logged in as someone else, you need to become superuser by typing: su - and not su

boomer ang
1st November 2004, 05:37 PM
Thanks about the explanation, infact it seems to work as you said. I still have a question : if I have only two user on my Linux , a root and a normal $ , when I type su I type the root psw but it doen't work, when I type su - it works but with the same previous psw.

The question is : why the root and unique psw could be associated to " two different root account " ?

Thanks in advance

Boomere

megaprogman
1st November 2004, 05:45 PM
su and su - are different in that su - assumes the shell variables of root (in root's bashrc file) wheras su just gives you the # while keeping your old shell variables.

boomer ang
1st November 2004, 05:52 PM
Thanks a lot for the explanation.

Is this rule valid for every distr ? This because I think to remember that simply "su" on a Mandrake 10 worked ,on my Fedora 2 not. Maybe my memory is like my knowledge :D


Thanks a lot and cheers


Boomer

megaprogman
1st November 2004, 11:00 PM
http://www.rt.com/man/su.1.html

ogetbilo
1st November 2004, 11:59 PM
Typing

/sbin/ifconfig

should work for both root and nonroot users.

boomer ang
3rd November 2004, 02:22 PM
Typing

/sbin/ifconfig

should work for both root and nonroot users.



Thanks a lot Ogetbilo, it works !!


Thanks to all


Boomer