PDA

View Full Version : floppy mount issue



dishawjp
31st October 2004, 09:25 PM
Hi All,

I thought I knew a bit about Linux, but this has me stumped. Ifr I try to mount a floppy as a normal user, I get teh following error:


[dishawjp@eunix dishawjp]$ mount /mnt/fd0 /mnt/floppy
mount: only root can do that
[dishawjp@eunix dishawjp]$


So I checked my /etc/fstab thinking that I had not yet set fd0 to user. Well, my /etc/fstab follows:


[root@eunix etc]# more /etc/fstab
LABEL=/1 / ext3 defaults 1 1
LABEL=/boot1 /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hdd3 swap swap defaults 0 0
/dev/hdc3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,user,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,user,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,user,kudzu 0 0
[root@eunix etc]#

Of course, since it's my computer, I do have root access and can mount floppies, but I don't give my wife or daughters root access, but still want them to be able to mount floppies if they choose to. What very basic thing am I overlooking here?

Thanks in advance.

megaprogman
31st October 2004, 10:29 PM
what about mount, what are the permission on that?

dishawjp
31st October 2004, 11:20 PM
Thanks for the quick reply. Users have execute permissions on /bin/mount and can mount /dev/cdrom and /dev/cdrom1. See below:


[dishawjp@eunix bin]$ ls -l mount
-rwsr-xr-x 1 root root 78504 May 4 17:34 mount
[dishawjp@eunix bin]$

imdeemvp
1st November 2004, 01:28 AM
try this line in your fstab: /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0 i see you have user instead of owner btw this is fc2 correct?

jayemef
1st November 2004, 02:31 AM
After checking my fstab, my line is exactly like the one profided by imdeemvp. So you may want to try that.

However, have you tried simply doing

mount /mnt/floppy
Since the item exists in your fstab, simply providing the mountpoint should be enough.

tashirosgt
1st November 2004, 02:36 PM
This would be a good place to ask if the permissions on the directories that are "mount points" also matter. I've never thought about that myself.

RedFedora
1st November 2004, 03:37 PM
I noticed that in the first post the command used was
mount /mnt/fd0 /mnt/floppy

Chances are this should have been
mount /dev/fd0 /mnt/floppy

dishawjp
2nd November 2004, 04:46 AM
Thanks for all the input.

RedFedora, the typo was a good catch on your part, but that was just a typo that happened when I was posting. That wasn't it. I checked permissions on /mnt and /mnt/floppy and both had execute permissions for all users. Looks like Jayemf found the solution, though I don't understand why that should have worked. See below:


[dishawjp@eunix dishawjp]$ mount /dev/fd0 /mnt/floppy
mount: only root can do that
[dishawjp@eunix dishawjp]$ mount /dev/fd0
[dishawjp@eunix dishawjp]$ umount /mnt/floppy
[dishawjp@eunix dishawjp]$

If I specify the mount point, I'm told that I need root permissions. If I don't specify the mount point, it just does it, yet I can umount it as a normal user.

As I said, all users have execute permissions on those directories, though root owns them.

Just an oddity that I'd never encountered before, and I usually specify mount points. Although I do have to admit that I use floppies a lot less than I used to years ago.

If anybody has any thoughts, please get back to me, but for now I guess I'm good to go.

Thanks again to all who took the time to post!