PDA

View Full Version : Package Management Question: I Need Rsync Protocol Version 29



bob p
30th January 2011, 02:06 AM
This is sort of a question about package management.

The F14 install that I am running on my desktop uses Rsync version 3.0.7, protocol version 30.

The backup server on my network that provides automated backup services for the entire LAN uses Rsync version 2.6.8, protocol version 29.

Because of incompatibilities in the way that hashes are generated in the different versions of Rsync, the backup server can not backup the F14 box because it's newer version of Rsync causes a backup failure, with Rsync issuing Exit Code 2, version incompatibility.

There are 2 obvious solutions to the problem:

A. Modify all of the boxes on the LAN to use Rsync with protocol version 30, or
B. Modify F14 to use Rsync with protocol version 29.

I'd like to take the easy way out, and revise the configuration on only one machine.

Can anyone tell me how to configure F14 so that it reverts from Rsync version 3.0.7 to a previous version that uses protocol version 29, and doesn't update this package in the future?

TIA.

PabloTwo
30th January 2011, 03:08 AM
Well, no promises this would work, but...... you could see if rsync-2.6.8 (http://koji.fedoraproject.org/koji/buildinfo?buildID=930), built for FC6, would install on your F14 machine. You would first need to uninstall your current version of rsync.. If you click on the "info" link on either the .i386 or x86_64 version on the link above and browse down to the "Requires" section, you'll see the requires are very modest and may actually install on F14 (or not).

If that installed without complaint, and worked to your satisfaction, then to keep the updates from replacing it you would add the following line to your /etc/yum.conf file:

exclude=rsync*

.... or add " rsync*" to an exiting exclude= line using a space as a separator from other entries.

markkuk
30th January 2011, 12:30 PM
Have you tried using the "--protocol=29" option for rsync on the F14 machine?