View Full Version : Nvidia driver killed me!

23rd January 2011, 09:25 PM
I went to the guide section and installed a driver for my Nividia card (GForce 8600 GT). Upon reboot it made it until the fedora icon fully shows up and froze prior to the mouse even showing up. Have been unable to reboot Fedora 14 in text mode and thus unable to directly run the guides suggestion for dealing with nouveau.

I know it is not the card for I have a triple boot system, Puppy, Ubuntu, and Fedora 14 and have with success installed the driver on both Puppy and Ubuntu.

Can I fix it remotely from Puppy by adding the "rdblacklist=nouveau" line in grub.conf and somehow dealing with the /boot/initramfs somehow? Or do I have to boot in run level 3 and do it from there? If the latter - how can one boot in run level 3 from Fedora 14????

P.S. - I see my system is listed below except that isn't my system any more - sorry (I'll see if I can get that changed)

23rd January 2011, 09:38 PM
Hi Troy,

I think (if you can get into the etc/innitab file) from Puppy, you can change the 5 to a 3 (in the last line), then boot into text mode...

23rd January 2011, 09:49 PM
well, when you boot.. when it freezes up, try hitting "Ctrl-Alt-F2" to get into a console terminal. From there, you can try editing the /boot/grub.conf file and make sure it has the 2 parameters on the end of the kernel line

nouveau.modeset=0 rdblacklist=nouveau

also, run:


Teh main thing that will do is to add 2 lines to your /etc/X11/xorg.conf file (these are for 32bit kernel, 64 bit will use /usr/lib64 instead)

ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"

Once those have been done, try rebooting and see if your problem is now fixed

23rd January 2011, 09:54 PM
Thanks. I checked and have no etc/innitab file. Did discover /etc/init/ck-log-system-restart.conf and in that noticed the line "start on runlevel 6" wherein I changed the 6 to a 3 and now I'm going for the dive!! Thanks again!

23rd January 2011, 09:58 PM
the filename is /etc/inittab :)

it has just 1 line in it (except for all of the comments..


23rd January 2011, 10:18 PM
Re: Post #2

My apologies.. Obviously I have a problem with that word..(inittab)..:C

24th January 2011, 01:28 AM
Boy today I am an idiot - after realizing inittab was a file and not a folder, and correcting my errors and doing the right thing, I did boot into level 3 - but then I botched up the command and killed the hole dang system - it wont boot at all now - I busted my Fedora once again! Can't seem to find an initramfs image to download to replace my busted up one with so may just reload F14 from scratch, again - lol

Thanks folks

---------- Post added at 04:28 PM ---------- Previous post was at 01:23 PM ----------

Reloaded Fedora and went through the process again of installing the Nvidia driver - again it froze on reboot. Tried the Ctrl-Alt F2 and it failed to work - went back into Puppy and changed the etc/inittab file to setting 3 which enabled reboot into text mode.

Once in the terminal I ran the sed, mv and dracut commands as stated in the nvidia driver guide - on reboot she worked just fine. Thanks folks