PDA

View Full Version : [SOLVED] Help...Grub again



Tenin
14th January 2011, 12:40 AM
recently i set up fedora in my main IDE, and keeping Vista in Sata.
while setting up fedora i plugged out the vista sata until the the set is done then reconnected the sata again. then i did some configuration to /boot/grub/menu.lst and /boot/grub/device.map and fstab files.

** /boot/grub/device.map
i add the line: (hd1) /dev/sda # for vista partition

** /etc/fstab
i add the line: /dev/sda1 /mnt/Vista ro 0 0

** /boot/grub/menu.lst
i added: title Windows Vista Ultimate
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1
makeactive

my partion layout;
hda1 for fedora
sda1 for vista

fdisk -l:
/dev/hda1 * 1 13 104391 83 Linux
/dev/hda2 14 4865 38973690 8e Linux LVM

/dev/sda1 * 1 10534 84609024 7 HPFS/NTFS
/dev/sda2 10534 19458 71678976 7 HPFS/NTFS

/dev/sdb1 1 36482 39303398 7 HPFS/NTFS


the problem is when i go for vista in the grub menu at the booting,it says BOOTMGR not found???
How can i boot to vista again?? plz any help??

just for info, when set the bios to boot directly from sata not ide i boot to vista successfully,but not by grub just directly.
the problem is that i need to boot to vista by grub.
thx in advance

DBelton
14th January 2011, 04:25 AM
when you boot from IDE..

you should have hd0 = /dev/hda and hd1 = /dev/sda

but.. you remap the drives when you want to boot vista...

so /dev/sda becomes hd0 and /dev/hda becomes hd1

BUT... you are telling it to look on hd1 for vista, yet it's been remapped so that it is now on hd0

try changing your rootnoverify line above to:

rootnoverify (hd0,0)

Tenin
14th January 2011, 07:07 PM
Thanks for the reply DBelton, i will try ur solution and post the result.

Tenin
15th January 2011, 03:18 PM
sorry to be late, but after testing your suggestion it give a new message "ERROR 13: Invalid or unsupported executable format"

stoat
15th January 2011, 06:00 PM
That "BOOTMGR is missing" indicates the grub.conf at that time was targeting the wrong NTFS partition. The "Invalid or unsupported executable format" thing indicates a typo in the grub.conf. If you are willing, take a moment to post the actual fdisk report and the entire grub.conf file. Copy those directly from the terminal into a post.

BTW, the device.map file does nothing during booting. It is only used by GRUB when we re-install GRUB, and even then only in certain circumstances. You can scramble the drive assignments in that file any way you want, and it still will boot or not boot as it did before. I've tried that many times. I once even booted my computer with only the Gettysburg Address in /boot/grub/device.map. But the device.map file needs to be right before you attempt to re-install GRUB. Anyway, in this matter of yours, the device.map file is a red herring. IMO, of course.

P.S.: I'm not sure where you're getting /dev/hda1 and /dev/hda2 in the hand-written fdisk excerpts above. Maybe some live CD. Anyway, Fedora stopped using those /dev/hdx device names with Fedora 7 which was when Fedora started using the same libata driver code for all hard drives. Anyway, I think this will work out better if you configure BIOS to boot Fedora. Leave it that way. Then boot into Fedora and get the fdisk information from a Fedora terminal. Then tweak GRUB to boot Windows. I also recommend that you not do anything to /etc/fstab until this is sorted out. A botched fstab can stop Fedora from booting.

Tenin
16th January 2011, 09:58 PM
thanks for the ur helps i just find the solution just rootnoverify(hd2,0)