PDA

View Full Version : Fedora 14 ATI Catalyst 10.11 Install



shnwmchk
11th December 2010, 01:16 PM
Step 1: Open Terminal
Step 2: Run as root in Terminal


su -And enter the root's password.

Step 3: Update the system
To make the installation less buggy.


yum updateStep 4: Install kernel-devel and gcc


yum install kernel-devel gccStep 5: Reboot
There's two ways to reboot:

[Main Menu] > [System] > [Shut Down] > [Restart]

OR


rebootStep 6: Download ATI Catalyst driver from official website:

http://www2.ati.com/drivers/linux/ati-driver-installer-10-11-x86.x86_64.run

Step 7: Repeat Step 1 & Step 2

Step 8: Execute the "ati-driver-installer-10-11-x86.x86_64.run"to install


bash ./ati-driver-installer-10-11-x86.x86_64.runStep 9: Move to /lib/modules/fglrx/build_mod


cd /lib/modules/fglrx/build_modStep 10: Compile the driver's module


sh make.sh
Step 11: Move to the outer directory


cd ..Step 12: Install the compiled driver's module

sh make_install.shStep 13: Add nomodeset to kernel row of /boot/grub/grub.conf file

Step 14: Repeat Step 5

Step 15: Done!

NOTE: 3D Acceleration and ATI Catalyst Control Center are available if the installation is success

Complete Version: http://shnwmchk.blogspot.com/2010/12/fedora-14-ati-catalyst-1011-install.html

leigh123linux
11th December 2010, 01:24 PM
Ok, Can you stop repeatedly posting this guide as I'm getting sick of clearing your posts from the moderation queue.

shnwmchk
11th December 2010, 01:29 PM
Ok, Can you stop repeatedly posting this guide as I'm getting sick of clearing your posts from the moderation queue.

Sorry. I stopped. This is the final version.

leigh123linux
11th December 2010, 01:30 PM
Sorry. I stopped. This is the final version.
The auto-moderation should cease when your post count = 6

gda2004
22nd December 2010, 11:03 AM
Hi Guys for anyone who is looking on this page atm I could only get the 10.11 to work not the 10.12 but simply follow the instructions as is and it should work :) but do try the .12 if you can get it to work let me know

slayerking
22nd December 2010, 11:48 AM
Hi Guys for anyone who is looking on this page atm I could only get the 10.11 to work not the 10.12 but simply follow the instructions as is and it should work :) but do try the .12 if you can get it to work let me know
The 10.11 and 10.12 ati installer works fine on F14 without any of these steps, Just run the installer choose automatic when it's done type aticonfig --initial then reboot.

gda2004
22nd December 2010, 12:30 PM
how does it work without compiling it ? is that already done inside the installiation wizard ?

slayerking
22nd December 2010, 01:24 PM
how does it work without compiling it ? is that already done inside the installiation wizard ?
You can either choose to generate a package for your distro if it is listed or select Automatic in the installer which yes compiles the module.

shnwmchk
23rd December 2010, 12:24 AM
You can either choose to generate a package for your distro if it is listed or select Automatic in the installer which yes compiles the module.

It didn't compiles the kernel modules automatically even I used the GUI installer. Thus, I showed how to compile the kernel manually.

slayerking
23rd December 2010, 05:20 AM
It didn't compiles the kernel modules automatically even I used the GUI installer. Thus, I showed how to compile the kernel manually.

Well you did something wrong then as that's what it does when you select automatic and always has done. It hasn't worked in earlier versions due to the xorg version being used in fedora but ati usually catches up(usually when the next release of fedora comes out).

I would say make sure you have the kernel-headers installed too as you only list the devel one there

bulava
28th December 2010, 11:59 AM
Could any confirm whether FC14 64-bit or the latest ATI Catalyst driver has any issues while installing/configuring this card:

Sapphire Toxic ATI 5850 - 2GB - DDR5

Thank you.

Bad2theBone
5th January 2011, 10:34 PM
do you need to disable compiz 3d effects? I'm currently running the OSS radeon drive with Compiz and Emerald Themes.

Nordic
7th February 2011, 03:51 AM
Well I got CCC installed without much issue, so thanks a lot for the guide/

However I am now faced with different issues.

I have an HD5770 with 2 19" monitors hooked up via VGA, and one 47" hooked to my mobo (HD3300) via HDMI. Initially upon install I had the 2 monitors working fine, after installing this driver though I only have the onboard graphics card. I've looked in CCC and it shows my 5770 as an "unknown adapter"

Does anyone have any suggestions?

jphase
23rd March 2011, 10:57 AM
Could any confirm whether FC14 64-bit or the latest ATI Catalyst driver has any issues while installing/configuring this card:

Sapphire Toxic ATI 5850 - 2GB - DDR5

Thank you.

I can confirm this problem. After installing Fedora Core 14 64bit and updating, I immediately installed the ati package. This created an endless loop on boot of black screen attempting to load something after the POST. It seems if you install the ati package before the kernel-devel and gcc packages (after updating) this problem occurs and is fixable by reinstalling (for me since I have no data to lose) or booting into a recovery terminal and removing/installing in the aforementioned order. Hope this helps.

datahal42
11th April 2011, 10:55 PM
do not need so many steps.

yum install dkms ("Dynamic Kernel Module Support Framework")

download de binary from ati. e.g: sh ati-driver-installer-11-3-x86.x86_64.run


some problem in leigth drivers : double image windows, some small issues in the firefox i dont konw why.

some problems with 32 bit library. with wine . s bit slow , maybe something in the compile options.

for now I prefer ati drivers

Hashman
29th April 2011, 05:02 AM
I can confirm, the latest ATI Linux driver that AMD just put out a few days ago works flawlessly with my 5000 series ATI graphics card and FC14. Smooth install too.