PDA

View Full Version : [SOLVED] Add repository



rishikoesal
4th December 2010, 07:14 PM
Hi all,

i have an question:

i want to install skype and have to do it maually, but when i type gedit /etc/yum.repos.d/skype.repo in terminal

i get this error:

[root@rkxl rishi]# gedit /etc/yum.repos.d/skype.repo

(gedit:5256): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

**
GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted (core dumped)
[root@rkxl rishi]#

don no what to do, can someone help me?

have te same problem with disabling SELINUX:

when i type gedit /etc/sysconfig/selinux i get this error:

[root@rkxl rishi]# gedit /etc/sysconfig/selinux

(gedit:5260): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

**
GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted (core dumped)
[root@rkxl rishi]#


I use Fedora 14 and with Fedora 13 i didn have this problem.
I am using Fedora for about six months.

Help me, Thanks

marko
4th December 2010, 07:20 PM
Hi all,

i have an question:

i want to install skype and have to do it maually, but when i type gedit /etc/yum.repos.d/skype.repo in terminal

i get this error:

[root@rkxl rishi]# gedit /etc/yum.repos.d/skype.repo

(gedit:5256): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

**
GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted (core dumped)
[root@rkxl rishi]#

don no what to do, can someone help me?

have te same problem with disabling SELINUX:

when i type gedit /etc/sysconfig/selinux i get this error:

[root@rkxl rishi]# gedit /etc/sysconfig/selinux

(gedit:5260): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

**
GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted (core dumped)
[root@rkxl rishi]#


I use Fedora 14 and with Fedora 13 i didn have this problem.
I am using Fedora for about six months.

Help me, Thanks

The problem seems to be just with running a gui app (gedit) as root. I don't know
how to fix the actual problem but
1) instead of editing the selinux config file directly, turn it off by running
system-config-selinux which is the admin tool intended for setting up selinux

2) if you just want to turn off selinux temporarily you can do that by the command:


setenforce 0
do the operation you wanted to do in selinux off mode, then turn it back on with:


setenforce 1

3) use a non-gui editor to do the edits, how about nano ?
as root user do:


yum install nano

nano is a very basic text editor and you don't need to remember the obscure key combos like vi or vim need.

jkerr82508
4th December 2010, 11:47 PM
To run GUI apps as root, you now need a root login shell:

su --login root
or in short form

su -
Note the space and dash after su

IIUC this provides an entire root environment rather than just changing user.

Jim

rishikoesal
5th December 2010, 10:10 AM
Thanks Marko and Jim.
Everything works fine now.

Thanks

Affix
5th December 2010, 01:40 PM
To run GUI apps as root, you now need a root login shell:

su --login root
or in short form

su -
Note the space and dash after su

IIUC this provides an entire root environment rather than just changing user.

Jim

you can use visudo and add your user to the sudoers file. You could also make a sudo group like I have and run a Graphical app like gedit for example


sudo gedit /etc/yum.repos.d/skype.repo

Does the same as "su -" only allowing you to run a single command (More if you pipe)