View Full Version : Installing fedora over pxe with a local network source

23rd November 2010, 11:42 AM

I've been always used to install fedora on my server this way : i put the fedora boot images on a pxe server, i copy the fedora install dvd to a ftp server, then i set the path of the dvd copy in the netinstall process.

But since a couple of release it doesn't work anymore, it keeps asking me for files in /repodata which doesn't exist on the dvd.

Is there any simple way to do this ? I tried cobbler using the dvd source, it create the repo fine with the proper files but it's too complicated, i just want the damn files.

Any idea how to do this ?

24th November 2010, 01:12 AM
I don't have an answer for you, Tibey, but I would like to ask you a question:

Do you copy the DVD to the FTP server as an ISO file, as files extracted from the ISO, or as a mounted ISO device?

I'm rather taken aback as I'm setting up Fedora on PXE for the first time and I'm surprised it keeps asking for an install.img file within the /image/ directory. I use ISO files.

I'm wondering if I'm doing something incorrectly, as I expected, like CentOS 5.5, I could simply point the pxeboot images to the DVD ISO file, and Fedora would mount and launch it. Instead I have to waste another 4 gigs on the server extracting it to a folder for it.
(Yes, I should be able to mount the ISO image to a folder within NFS so the client can load and install it, without wasting any disk space. Unfortunately it refuses to mount this; permission denied. Still working through this one.)

24th November 2010, 11:10 AM
I use files extracted from the dvd iso.

Anybody here can help me ? :confused: I just want a simple way to do a netinstall without having to go online to get the install files (i don't have a huge bandwidth)

---------- Post added at 11:10 AM GMT ---------- Previous post was at 10:58 AM GMT ----------

FoxKeegan finaly you answered my question without wanting to, i tried to mount the iso in linux and the files are now ok.

Turns out the files names on repodata are larger than 64 char so nor winrar or 7zip on windows recognize them well : they truncate the name after 64 char.

Why the hell these filename are so long ?!!

24th November 2010, 12:31 PM
@FoxKeegan, no, you're not doing something incorrectly. Yes, CentOS can do it, Fedora can't. Not sure why, but it's been that way for awhile.

I'm not sure if there was a workaround--I remember when I first ran into the issue, and have the feeling that all I had to do was mount -o loop the iso, and point the installation there, but it's been awhile. So, I didn't have to actually
copy the files over.

24th November 2010, 02:37 PM
Glad to see I helped a bit at least.

Unfortunately it doesn't seem like you can mount an ISO (with -o loop or ro) and then have it mounted by another machine with NFS. The permissions are always denied. (From everything I've read online)

I'm working on mounting the ISO and installing via FTP. I just hate deviations, was hoping they'd all just run from ISO across NFS.

Eventually I'll get this all kickstarted, provided Fedora supports that. The real pain will be getting the LiveCD to run from PXE.

(This PXE server will support Clonezilla, CentOS, Fedora, OpenSuSE, DSL, Crunchbang and Ubuntu)