PDA

View Full Version : Fedora14 lxde on asus eee pc 701 4G



polle58
18th November 2010, 06:13 PM
Recently I bought myself a second hand eee pc (celeron 900 mhz, 512Mb ram, 4G SSD)
I didn't like the default xandros, changed it direct for puppeee. As the eee pc boots easy from usb I wanted to try various os onit, easypeasy went without problems. Now I wanted to try the lxde spinoff of fedora14. It worked but not without difficulties.
As the eee pc has no cdrom and I don't have an external cdrom player, I first tried to make a bootable usb stick from the live iso with unetbootin (installed on my suse 11.2 desktop) But when I booted the eee pc from the created usbstick , I got the fedora splashscreen, but after a few seconds got the message: " no root device found, sleeping forever". When I googled a bit found out that this was a bug in earlier versions, but it should be ressolved. I tried to change the kernelparameters, but could not get the usbstick to boot. Tried the stick on my desktop pc, same result.
Then I burned the live iso to cd and booted it on my desktop pc, this went without problems.
Fired up the installer and installed on the usb stick, first time I manually choose the partitions (one for boot and one for /) the installation went fine, but when I booted from the usb stick only got a blinking cursor.
Tried again this time I let the installer use the entire (usb)disk and let the installer make the partitions.
This usb stick booted perfect from my eee pc, the only problem was that on first boot you have to create a user and somemore things, but the windows was greater then my screen and I could not scroll to the part that was hidden. Managed that by going with th "tab" button to the hidden entrys,when finished I had a working sustem on usb.
Works quite well on this limited hadware, boottime 55sec. Wirelss worked out of the box after giving the passfrase for WPA.
Need to do some further testing, but first impressions are very good,

CSchwangler
20th November 2010, 08:41 AM
You should have either Fedora live-usb-creator or just dd instead of unetbootin

https://fedorahosted.org/liveusb-creator/
http://docs.fedoraproject.org/en-US/Fedora/14/html/Installation_Guide/Making_USB_Media-UNIX_Linux.html#Making_USB_Media-UNIX_Linux-RHEL_Fedora-dd

I never was successful in using unetbootin with Fedora, while live-usb-creator more often than not works just fine.

smr54
20th November 2010, 01:23 PM
As CSchwangler says (second time I wrote that this morning) unetbootin can be problematic with Fedora. (I can get it to do a netinstall, but it's not intuitive.)

Most modern distributions should work out of the box with the older eee PCs. I think most of them had an Atheros b/g wireless, which is usually supported pretty well by the ath5k module.