PDA

View Full Version : Cants install kdenlive via yum in fedora 14 x64



xpzion7
16th November 2010, 10:40 PM
Cant install kdelive in fedora 14 x64


yum install kdenlive
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Adding en_US to language list
Loading mirror speeds from cached hostfile
* fedora: mirrors.tummy.com
* rpmfusion-free: mirrors.tummy.com
* rpmfusion-free-updates: mirrors.tummy.com
* rpmfusion-nonfree: mirrors.tummy.com
* rpmfusion-nonfree-updates: mirrors.tummy.com
* updates: mirrors.tummy.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package kdenlive.x86_64 0:0.7.7.1-1.fc13 set to be installed
--> Processing Dependency: dvgrab for package: kdenlive-0.7.7.1-1.fc13.x86_64
--> Processing Dependency: libmlt.so.2()(64bit) for package: kdenlive-0.7.7.1-1.fc13.x86_64
--> Processing Dependency: libmlt++.so.3()(64bit) for package: kdenlive-0.7.7.1-1.fc13.x86_64
--> Running transaction check
---> Package dvgrab.x86_64 0:3.5-1.fc13 set to be installed
---> Package kdenlive.x86_64 0:0.7.7.1-1.fc13 set to be installed
--> Processing Dependency: libmlt.so.2()(64bit) for package: kdenlive-0.7.7.1-1.fc13.x86_64
--> Processing Dependency: libmlt++.so.3()(64bit) for package: kdenlive-0.7.7.1-1.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: kdenlive-0.7.7.1-1.fc13.x86_64 (rpmfusion-free)
Requires: libmlt.so.2()(64bit)
Error: Package: kdenlive-0.7.7.1-1.fc13.x86_64 (rpmfusion-free)
Requires: libmlt++.so.3()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

glennzo
16th November 2010, 11:26 PM
Tried this on my 32Bit Fedora 14 system and got the same errors. Wonder where to get those missing packages?

ozjd
16th November 2010, 11:43 PM
Won't help but I installed kdenlive just after F14 came out and it worked without problems. So I'm guessing a package has gone missing or the dependencies have been changed. Same version too. Came from rpmfusion-updates.

If you don't have it trying installing mlt.

Valent
19th November 2010, 11:18 PM
I reported this as a but and there is a solution in this bugreport also:
https://bugzilla.rpmfusion.org/show_bug.cgi?id=1527

---------- Post added at 11:18 PM GMT ---------- Previous post was at 11:18 PM GMT ----------

I reported this as a but and there is a solution in this bugreport also:
https://bugzilla.rpmfusion.org/show_bug.cgi?id=1527

ozjd
19th November 2010, 11:28 PM
It says that mlt is missing from RPMFusion but it shows as being there in rpmfusion-free-updates

I'm guessing that is out of date.

xpzion7
5th December 2010, 07:31 PM
Solution:

yum --enablerepo=rpmfusion-free-updates-testing -y install kdenlive

darkscot
13th May 2011, 08:20 AM
Thank you for this! I have just had the same problem and this sorted it.

himansu
14th May 2011, 09:15 AM
Thank you very much. I solve my problem with this post

ozjd
15th May 2011, 02:15 AM
It seems that occasionally mlt and kdenlive updates get out of sync. kdenlive takes a while to catch up when a new version of mlt is released.