PDA

View Full Version : [SOLVED] updating problems



DIONISIS POLITI
13th November 2010, 06:31 PM
for some reason my first updating was interrupted and from then i cannot update. i get the following message:

rpmdb: PANIC: fatal region error detected; run recovery
error: db3 error(-30974) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed

[root@laptop etc]# yum repolist

rpmdb: PANIC: fatal region error detected; run recovery
error: db3 error(-30974) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed

[root@laptop etc]# yum clean all

rpmdb: PANIC: fatal region error detected; run recovery
error: db3 error(-30974) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

what am i supposed to do

glennzo
13th November 2010, 07:10 PM
I would remove the databases and then rebuild them

su -
<password>
cd /var/lib/rpm
rm __db*
rpm --rebuilddb
See if yum springs to life now.

DIONISIS POLITI
13th November 2010, 07:36 PM
oh! it seems to function now. very simple but so effective. Thank you so much!
if i will encounter something else i ' ll come back!
Thanks again!

glennzo
13th November 2010, 09:49 PM
Break something on purpose. Then you will have to come back again :p Otherwise we may never see you again!

DIONISIS POLITI
16th November 2010, 07:19 PM
you bet you will!
anyway i have a really problem but i was looking for an answer into the various threads , for a couple of days, so i didn't post so far. what is that : when i 'm trying to play a video -an .avi file or a dvd- the laptop freezes, i have to restart it from the power button. That's happening with totem and the vlc. i have downloaded the codecs via Autoten. any idea?
i found similar but not the same problem to some threads and i could not figure out what's happening.Do i have to post to another topic?

glennzo
16th November 2010, 09:54 PM
No idea. Next time the laptop freezes see if CTRL/ALT/F2 gets you to a command line log in. If so, log in and check the logs in /var/log (as root) and check .xsession.errors in your home folder. If not, reboot and check them.