PDA

View Full Version : Rawhide installation



ezeaguerre
5th November 2010, 04:03 AM
Hi! I have a couple of questions, but first... this is how I installed rawhide (following this guide: http://fedoraproject.org/wiki/Releases/Rawhide):

1. Installed Fedora 14
2. Enter here: http://koji.fedoraproject.org/koji/packageinfo?packageID=9
3. Then to the fedora-release-15-0.3: http://koji.fedoraproject.org/koji/buildinfo?buildID=195502
4. Downloaded both rpms:
* http://kojipkgs.fedoraproject.org/packages/fedora-release/15/0.3/noarch/fedora-release-rawhide-15-0.3.noarch.rpm
* http://kojipkgs.fedoraproject.org/packages/fedora-release/15/0.3/noarch/fedora-release-15-0.3.noarch.rpm

When reading the guide, I couldn't understand if "Check the latest build on Koji" meant the latest by build date or by release number... :S anyway... I went with the release number choice...

5. rpm -Uvh fedora-release-*.noarch.rpm.

6. Went through /etc/yum.repos.d/*.repo and left enabled only the rawhide repo:



[eze@solaris ~]$ yum repolist
Complementos cargados:downloadonly, langpacks, presto, refresh-packagekit
Adding es_AR to language list
id del repositorio nombre del repositorio estado
*rawhide Fedora - Rawhide - Developmental packages for the next 22.537
repolist: 22.537
[eze@solaris ~]$


7. yum update

It seems I have the rawhide version now, but I wanted to ask if this is the correct procedure, because gdm is not working, and everytime the system boots it presents me a prompt saying fsck failed... I run manually fsck and everything ok... then telinit 2 and startx (can't login through gdm).

If this is the correct procedure then... should I search and report those problems in bugzilla?

I also tried to install rawhide passing the boot option "askmethod", but didn't work, Anaconda _NEVER_ asked me to use another repo... so, how should I install rawhide directly through Anaconda?

I read this in the guide:

"If you already have a bootable CD, DVD, USB stick, or hard drive partition containing the *-DVD.iso or *-disc1.iso, you can use that to install Rawhide. However, if you need to download new boot media, these files are not recommended because they contain general release versions of Fedora RPMs, and you wish to install Rawhide RPMs. See installation guide download page for instructions if you want to download these files anyway. A general release Live image cannot be used to install Rawhide, only the general release version of Fedora which it contains can be used."

Don't really understand what it means, does it mean I need to first install Fedora (a "general release version of Fedora") and then use that system to install rawhide (like I did)?

I also tried the minimal installer option... but it couldn't find the "installer.img" file on the repository, so I tried the latest release (13 at the time), but throwed a Python exception at the partitioning stage and all the time spent downloading the file was useless...
The guide says this: "2010-04-09 Note: Anaconda 13.37.2 does not work here because the os/install.img cannot be found at any mirror including the master."
Don't know what version of Anaconda was in the minimal installer iso, but I couldn't use Anaconda to install rawhide :-(

So, these are the questions:
* What I did was the correct procedure to install rawhide?
* If so, should I report the bugs in bugzilla? or what?
* How should I install rawhide directly through Anaconda? (without having to install the latest release first).

These ones are not related to the rest of the post:
* How often the rawhide repos are updated? I have nothing to update with "yum update"
* Why there's nothing here: ftp://ftp.uninett.no/pub/linux/Fedora/development/x86_64/os/Packages/ ?

Thanks :)

downer
5th November 2010, 01:29 PM
To try and answer a few of your questions:

everytime the system boots it presents me a prompt saying fsck failed... I run manually fsck and everything ok...
I just ran into the same problem http://forums.fedoraforum.org/showthread.php?t=253563 and reported the bug. Ctrl-D to exit the dracut shell and boot normally works for me.

How should I install rawhide directly through Anaconda? (without having to install the latest release first)
There may be a better way to do it, but I just changed the repo from "13" to "rawhide" on my install DVD for a fresh install without doing an upgrade. But after an upgrade you can do "yum --releasever=rawhide distro-sync" to make sure all of your packages are from the Rawhide repo.

How often the rawhide repos are updated? I have nothing to update with "yum update"
From http://www.fedora.redhat.com/wiki/Releases/Rawhide
"Rawhide is automatically generated once daily from the latest packages that are built. Packages that are built one day are generally in rawhide the next day. For the curious, the build is done at Midnight US Eastern, 0400/0500 UTC."
The updates are pretty sporadic, and usually need "--skip-broken".

ezeaguerre
6th November 2010, 02:35 AM
I just ran into the same problem http://forums.fedoraforum.org/showthread.php?t=253563 and reported the bug. Ctrl-D to exit the dracut shell and boot normally works for me. Yes, CTRL+D works :)


There may be a better way to do it, but I just changed the repo from "13" to "rawhide" on my install DVD for a fresh install without doing an upgrade. You mean... edit /etc/yum.repos.d/* on the live image and then proceed with the install? Because Anaconda doesn't let me choose the repo...


But after an upgrade you can do "yum --releasever=rawhide distro-sync" to make sure all of your packages are from the Rawhide repo. mmm... interesting... I did what you say and downloaded 23 MB of packages, and there are 33 ignored packages (because of dependency problems). However, "yum upate" or "yum distro-sync" does nothing, I have to add the option "--releasever=rawhide". That means I did something wrong when updating to rawhide, right?



[root@solaris eze]# ls /var/cache/yum/x86_64/15/rawhide
9fd952b4cc620d9036162b24f0429668c5415ba95132b43ccd 42b91475485b83-primary.sqlite cachecookie metalink.xml packages repomd.xml
[root@solaris eze]# ls /var/cache/yum/x86_64/rawhide/rawhide
b66f962feb198155c04fa86a2065157fbb23debcb702731065 a8c966b9959417-primary.sqlite metalink.xml
cachecookie packages
cec5e55562d277275dd3cc9c511f61f89e15f9be1211c629d3 0c638f0d0aea48-filelists.sqlite repomd.xml
[root@solaris eze]#


The --realesever=rawhide added the /var/cahce/yum/x86_64/rawhide/rawhide and the difference between that and the previous rawhide cache I have in /var/cache/yum/x86_64/15/rawhide is the *-filelists.sqlite file.
What was my mistake?



From http://www.fedora.redhat.com/wiki/Releases/Rawhide
"Rawhide is automatically generated once daily from the latest packages that are built. Packages that are built one day are generally in rawhide the next day. For the curious, the build is done at Midnight US Eastern, 0400/0500 UTC."
The updates are pretty sporadic, and usually need "--skip-broken".

OK, then I'm doing something terribly wrong :P
For example, this is a "near" mirror: http://fedora.c3sl.ufpr.br/linux/development/rawhide/x86_64/os/
But there is absolutely NOTHING in the Packages directory: http://fedora.c3sl.ufpr.br/linux/development/rawhide/x86_64/os/Packages/

This is my /etc/yum.repos.d/fedora-rawhide.repo:



# These packages are untested and still under development. This
# repository is used for development of new releases.
#
# This repository can see significant daily turnover and major
# functionality changes which cause unexpected problems with other
# development packages. Please use these packages if you want to work
# with the Fedora developers by testing these new development packages.
#
# fedora-test-list@redhat.com is available as a discussion forum for
# testing and troubleshooting for development packages in conjunction
# with new test releases.
#
# More information is available at http://fedoraproject.org/wiki/Testing
#
# Reproducible and reportable issues should be filed at
# http://bugzilla.redhat.com/.
#
# Product: Fedora
# Version: rawhide

[rawhide]
name=Fedora - Rawhide - Developmental packages for the next Fedora release
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/$basearch/os/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=$basearch
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[rawhide-debuginfo]
name=Fedora - Rawhide - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/$basearch/debug/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=rawhide-debug&arch=$basearch
enabled=0
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[rawhide-source]
name=Fedora - Rawhide - Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/source/SRPMS/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=rawhide-source&arch=$basearch
enabled=0
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch


Is there something wrong with it?

Thank you :-)

downer
6th November 2010, 04:03 AM
You mean... edit /etc/yum.repos.d/* on the live image and then proceed with the install? Because Anaconda doesn't let me choose the repo...
No, I used the install DVD, and not the live image. The install DVD lets you edit repos. That's what Fedora must have been trying to say when they said not to use a live image to install Rawhide. I would've used the install CD, but I couldn't get it, the nightly builds, or any other method to boot on my computer.


mmm... interesting... I did what you say and downloaded 23 MB of packages, and there are 33 ignored packages (because of dependency problems). However, "yum upate" or "yum distro-sync" does nothing, I have to add the option "--releasever=rawhide". That means I did something wrong when updating to rawhide, right?
After you upgrade to Rawhide like the Wiki says:

yum install fedora-release-rawhide
yum --disablerepo=* --enablerepo=rawhide update
you still have to disable the repos for other releases.

This is what I get when I run "yum repolist"

Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated 18
rawhide Fedora - Rawhide - Developmental pack 18,191
rawhide-debuginfo Fedora - Rawhide - Debug 5,399
rpmfusion-free-rawhide RPM Fusion for Fedora Rawhide - Free 538
rpmfusion-free-rawhide-debuginfo RPM Fusion for Fedora Rawhide - Free 198
rpmfusion-nonfree-rawhide RPM Fusion for Fedora Rawhide - Nonfr 210
rpmfusion-nonfree-rawhide-debuginfo RPM Fusion for Fedora Rawhide - Nonfr 71
repolist: 24,625

Go into "/etc/yum.repos.d/" and make sure any repos that aren't Rawhide are not enabled.

"yum --releasever=rawhide distro-sync" may need "--skip-broken" added, just like most times when I use yum with Rawhide and don't want to wait for dependencies to be built. I really only needed distro-sync when I upgraded from F14 Updates-Testing, since I had some of their newer(!?) packages leftover. (For now, I may end up going back and using a few F14 Updates-Testing packages for better Nouveau performance.)

Just food for thought, the wiki comes with a pretty strong warning about Rawhide:
"End users should not use Rawhide as their main day-to-day workstation. Because Rawhide is a development branch, many changes are not heavily tested (or tested at all) before being released to Rawhide, and packages in Rawhide can and do break without warning. It is even possible that bugs in Rawhide could cause data loss."

ezeaguerre
6th November 2010, 05:25 AM
No, I used the install DVD, and not the live image. The install DVD lets you edit repos. That's what Fedora must have been trying to say when they said not to use a live image to install Rawhide. I would've used the install CD, but I couldn't get it, the nightly builds, or any other method to boot on my computer. Oh, thanks :-)



After you upgrade to Rawhide like the Wiki says:

yum install fedora-release-rawhide
yum --disablerepo=* --enablerepo=rawhide update
you still have to disable the repos for other releases.

This is what I get when I run "yum repolist"

Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated 18
rawhide Fedora - Rawhide - Developmental pack 18,191
rawhide-debuginfo Fedora - Rawhide - Debug 5,399
rpmfusion-free-rawhide RPM Fusion for Fedora Rawhide - Free 538
rpmfusion-free-rawhide-debuginfo RPM Fusion for Fedora Rawhide - Free 198
rpmfusion-nonfree-rawhide RPM Fusion for Fedora Rawhide - Nonfr 210
rpmfusion-nonfree-rawhide-debuginfo RPM Fusion for Fedora Rawhide - Nonfr 71
repolist: 24,625

Go into "/etc/yum.repos.d/" and make sure any repos that aren't Rawhide are not enabled.

I'm sure I disabled the other repos...



[root@solaris ~]# yum repolist
Loaded plugins: downloadonly, langpacks, presto, refresh-packagekit
Adding en_US to language list
repo id repo name status
*rawhide Fedora - Rawhide - Developmental packages for the next Fedora release 0
repolist: 0
[root@solaris ~]# yum repolist -v
Not loading "blacklist" plugin, as it is disabled
Loading "downloadonly" plugin
Loading "langpacks" plugin
Loading "presto" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Adding en_US to language list
Config time: 0.036
Yum Version: 3.2.28
Setting up Package Sacks
Repo-id : rawhide
Repo-name : Fedora - Rawhide - Developmental packages for the next Fedora release
Repo-revision: 1288858710
Repo-tags : binary-x86_64
Repo-distro-tags: [cpe:/o:fedoraproject:fedora:15]: rawhide
Repo-updated : Thu Nov 4 05:19:39 2010
Repo-pkgs : 0
Repo-size : 0
Repo-metalink: https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=x86_64
Updated : Fri Nov 5 06:07:21 2010
Repo-expire : 21,600 second(s) (last: Fri Nov 5 22:30:29 2010)

repolist: 0
[root@solaris ~]# for i in /etc/yum.repos.d/*; do echo $i; cat $i | grep enabled; done
/etc/yum.repos.d/fedora-rawhide.repo
enabled=1
enabled=0
enabled=0
/etc/yum.repos.d/fedora.repo
enabled=0
enabled=0
enabled=0
/etc/yum.repos.d/fedora-updates.repo
enabled=0
enabled=0
enabled=0
/etc/yum.repos.d/fedora-updates-testing.repo
enabled=0
enabled=0
enabled=0



"yum --releasever=rawhide distro-sync" may need "--skip-broken" added, just like most times when I use yum with Rawhide and don't want to wait for dependencies to be built. I really only needed distro-sync when I upgraded from F14 Updates-Testing, since I had some of their newer(!?) packages leftover. (For now, I may end up going back and using a few F14 Updates-Testing packages for better Nouveau performance.) Yes, I added --skip-broken :-)


Just food for thought, the wiki comes with a pretty strong warning about Rawhide:
"End users should not use Rawhide as their main day-to-day workstation. Because Rawhide is a development branch, many changes are not heavily tested (or tested at all) before being released to Rawhide, and packages in Rawhide can and do break without warning. It is even possible that bugs in Rawhide could cause data loss." Yes, I'm aware of the problems with Rawhide, but I want to test and be useful somehow :P
My main distro is not rawhide... and I didn't wanted to use a virtual machine to test rawhide because I wanted to test it on real hardware.

tox
6th November 2010, 06:15 AM
another how to install rawhide http://www.fedora.redhat.com/wiki/Releases/Rawhide#Direct_Rawhide_install_via_Live_installer

just another note, i think you can also install rawhide by PreUpgrade by just choosing to install Rawhide

http://fedoraproject.org/w/uploads/8/88/Features_PreUpgrade_2-version.png


just install PreUpgrade-gui package

ezeaguerre
7th November 2010, 08:37 AM
Thanks! didn't know about preupgrade.
The other method was not available a week ago... :-(

I would like to understand exactly what is going on... but as the last resource I'll use one of those 2 methods, thanks :-)

martyfelker
2nd January 2011, 03:03 AM
and saaafatest This is how I got to Fedora 15 Rawhide and its the fastest and safest way I know.

1) Install Fedora 14 from install DVD. After partitioning (be extra careful about this if you have other OS on your machine you may not want to isntall GRUB on the MBR in that case).

2) Choose customize now or later - doesn't ' really matter - customize now installs a minimal GNOME desktop).)

3) After booting I immediately set-up sudo by using nano to edit the sudoers file and uncommneting the %whell line) - then enable your user groups to add yourself to wheel.

4) Run the following command (you can break it up if you wish) sudo yum install -y yumex && sudo install -y fedora-release-rawhide && sudo yum -y distribution-synchronization

5) Use teh Softwarfe Sources applet under administration to disable fedora repo fedora updaets repo and fedora updates-testing reop and enable fedodra rawhide repo.

6) When you run yumex it will only dislay update to rawhide. In fact you may just immediately get a prompt to iinstall updates "safely - like ubunt k apt-ge saafe upgrade).

7) FWIW I first add the new kernel (2.6.37) and proceed from there. As the Wiki says you do need to be prepaaaared to start over from item 1 is you add or subtract the wrong programs from Rawhide. I stay away from updating the Xorg- drivers and the boot programs. I also happen to run sudo yum install -y KDE to add the KDE desktop which I find is more stable than Gnome. This takes about me 3 hours istworks every time. Because I have an ancient NVidia video card installing rawehide from a nightly build gives me screens of death in many colours.

Your mileage will probably vary.

Have a lot of fun as openSUSE says!

Marty Felker