View Full Version : A little help

20th October 2010, 12:48 AM
Im new to Fedora and am really enjoying it so far! I was wondering if someone could tell me what is installed in Fedora 14 beta that makes touchscreens work? (atleast mine anyway) I tried to get my touchscreen to work in Fedora 13 with no luck..... Any advice would be appreciated! The reason im asking is because im having a few bugs in F14 and would rather wait for its full release before using it. if it helps this is my computer and a Ubuntu wiki on it (I switched from Ubuntu)


20th October 2010, 12:49 AM
(moved to F14 Development)

20th October 2010, 09:25 PM
Well, probably just an updated driver in the kernel or X. You could try booting with an F14 kernel on your F13 install. But it's probably best to stick with F14, if you install F14 Beta or Final TC and do all updates what you have is 99.9% Fedora 14 final anyway. What bugs are you having?

21st October 2010, 05:33 AM
Just basic stability problems. Its been alot better since Ive done a reinstall of F14. No problems what so ever so far. Except I can install hardly any RPM files. I get a python error for almost all of them.

I always get something like this

eee-control-0.9.6-2pclos2010.i586 requires libpython2.6.so.1.0
eee-control-0.9.6-2pclos2010.i586 requires python < 2.7
eee-control-0.9.6-2pclos2010.i586 requires python-notify
eee-control-0.9.6-2pclos2010.i586 requires python-dbus
eee-control-0.9.6-2pclos2010.i586 requires python-smbus
eee-control-0.9.6-2pclos2010.i586 requires gnome-python-gconf
eee-control-0.9.6-2pclos2010.i586 requires rpm-helper
eee-control-0.9.6-2pclos2010.i586 requires python-base >= 2.6

usually its only the 1st 2 though. But it wont let me install them it always says I have a newer version.

21st October 2010, 06:02 PM

Are you trying to install a rpm package from a different distro (PCLOS)?

21st October 2010, 06:40 PM
In this situation it seems so. But it does the same thing for one.s for Fedora

Sorry about that I was just tryig to find an RPM to show you. Here is what I normally get

eee-control-0.9.6-1.fc13.i686 requires libpython2.6.so.1.0
eee-control-0.9.6-1.fc13.i686 requires python(abi) = 2.6

23rd October 2010, 01:00 AM
You can't install Fedora 13 packages on Fedora 14, either, usually. It's perfectly normal to see problems like that if you try. You should stick to packages built for Fedora 14.

23rd October 2010, 01:05 AM
What if there isnt a F14 package though?

23rd October 2010, 07:08 AM
You can try to compile it from source, but there may also be dependency problems.

23rd October 2010, 06:33 PM
Ive been having trouble with installing from source in Fedora.

Im trying to install this

wat do I do/am doing wrong?

[clate@clate-computer ~]$ su
[root@clate-computer clate]# cd Desktop
[root@clate-computer Desktop]# cd eee-control-0.9.4
[root@clate-computer eee-control-0.9.4]# sudo ./setup.py
usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
or: setup.py --help [cmd1 cmd2 ...]
or: setup.py --help-commands
or: setup.py cmd --help

error: no commands supplied
[root@clate-computer eee-control-0.9.4]#

23rd October 2010, 07:10 PM
first, don't compile as root; only install as root.

second, doing 'su' and then 'sudo somecommand' is redundant; as soon as you did 'su', and the prompt changed from $ to #, you were root already, sudo wasn't doing anything useful. On Fedora people generally use 'su' rather than 'sudo'.

third, you didn't supply a command for setup.py - setup.py files are usually produced from python-setuptools and you usually use them like this:

$ python setup.py build
(wait for the build to complete)
$ su
(enter root password)
# python setup.py install

try that. You may find the build fails at first; if so, don't run the install step, just post the failure here and we'll help out.

23rd October 2010, 10:32 PM
Any ideas? Did I do it right? Also there is a eee-control-setup.sh file in there should I use this or?
Also thanks yall have been very helpful. Im still learning the differences in Fedora ad Ubuntu. I will get there eventually lol

[clate@clate-computer ~]$ cd Desktop
[clate@clate-computer Desktop]$ cd eee-control-0.9.4
[clate@clate-computer eee-control-0.9.4]$ python setup.py build
running build
running build_py
creating build
creating build/lib.linux-i686-2.7
creating build/lib.linux-i686-2.7/EeeControl
copying EeeControl/actions.py -> build/lib.linux-i686-2.7/EeeControl
copying EeeControl/utils.py -> build/lib.linux-i686-2.7/EeeControl
copying EeeControl/__init__.py -> build/lib.linux-i686-2.7/EeeControl
copying EeeControl/she.py -> build/lib.linux-i686-2.7/EeeControl
copying EeeControl/tray.py -> build/lib.linux-i686-2.7/EeeControl
copying EeeControl/ichsmbus.py -> build/lib.linux-i686-2.7/EeeControl
copying EeeControl/config.py -> build/lib.linux-i686-2.7/EeeControl
copying EeeControl/daemonize.py -> build/lib.linux-i686-2.7/EeeControl
copying EeeControl/models.py -> build/lib.linux-i686-2.7/EeeControl
running build_ext
building 'EeeControl.ioport' extension
creating build/temp.linux-i686-2.7
creating build/temp.linux-i686-2.7/ioport
gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fwrapv -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fwrapv -fPIC -I/usr/include/python2.7 -c ioport/ioport.c -o build/temp.linux-i686-2.7/ioport/ioport.o
unable to execute gcc: No such file or directory
error: command 'gcc' failed with exit status 1
[clate@clate-computer eee-control-0.9.4]$ su
[root@clate-computer eee-control-0.9.4]# python setup.py install
running install
running build
running build_py
running build_ext
building 'EeeControl.ioport' extension
gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fwrapv -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fwrapv -fPIC -I/usr/include/python2.7 -c ioport/ioport.c -o build/temp.linux-i686-2.7/ioport/ioport.o
unable to execute gcc: No such file or directory
error: command 'gcc' failed with exit status 1
[root@clate-computer eee-control-0.9.4]#

---------- Post added at 09:32 PM GMT ---------- Previous post was at 09:04 PM GMT ----------

Also I may not be on for a couple days. Im gonna be very busy this weekend. I will get back to this ASAP

25th October 2010, 07:29 AM
Fedora uses cpuspeed daemon to automatically set CPU speed and fans. In most cases this is fine.
Did you install some non-standard repo?
Are you trying to overclock?
cpufreq-selector -h
cpuspeed -h

25th October 2010, 05:33 PM
Yes im trying to overclock it. It worked fine in Ubuntu but am still trying to make it work in Fedora

25th October 2010, 10:26 PM
it's missing the gcc command, so:

# yum install gcc

then try the build step again.

25th October 2010, 10:36 PM
Besides installing the compiler, it might be good to install the development
libraries too.

25th October 2010, 10:57 PM
[root@clate-computer clate]# yum install gcc
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Package gcc-4.5.1-4.fc14.i686 already installed and latest version
Nothing to do
[root@clate-computer clate]#

Same thing I got when I tried to install the python dependencies

---------- Post added at 09:57 PM GMT ---------- Previous post was at 09:49 PM GMT ----------

What am I doing wrong? Im sure its something im doing. But I cant figure it out.

26th October 2010, 01:51 AM
not sure, actually. what happens if you just run 'gcc' at a console?