PDA

View Full Version : [solved] how to return nvidia graphics to nouveau drivers?



lambcutlet
8th October 2010, 10:03 PM
hello,

some how my pc has got its graphics screwed up.

hardware, AMD quad 965, 4GB, 1GB raid 10, nvidia GTX240
software F13 64bit, nvidia drivers as per Leighs installation in the guides. all updated with yum to the latest versions.

one day i returned from work and the display was garbage. i don't know if it was an update or its was the kids tinkering whilst watching cbeebies.
i run a twinview (2 display). right now i have the RHD screen with the fedora swirl and the LHD screen has a mouse cursor zoomed in by about 20x.
move the mouse and the LHD screen seems to have a black box contained within a grey border.

i did have it set to automatically login but this has stopped functioning as well.

i know its not a hardware issue as i loaded a F13 live CD just to check and all is well.

i have been trying to return the graphics to either nouveau or vesa. in a effort to restore the graphics.
i have tried reinstalling leighs guide with no success.

currently i am accessing the system via ssh so i know the system is fine.

question: how do i return the graphics system to the default fedora setup?

once fixed i can reload the nvidia drivers.
i've been messing with this for the past week with no success.
please help.

---------- Post added at 10:03 PM GMT ---------- Previous post was at 08:35 PM GMT ----------

i don't frigging believe it, my problems were due to the 'Automatic login'
/etc/gdm/custom.conf
the file was empty

i added this
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=username
TimedLoginEnable=true
TimedLogin=username
TimedLoginDelay=0
currently being dicussed here:
http://fedoraforum.org/forum/showthread.php?t=246223

rebooted, then low and behold my desktop appeared. i'm stunned.

anyway running on nouveau drivers going to load nvidia presently

schotty
9th October 2010, 05:33 AM
if you do a ctrl+alt+f2 you should be able to get to a local login,

as root, switch to runlevel 3 (text login, will kill x off so you can quick fix it):
teleinit 3

then you can edit (going from memory since I am at work, with windows only systems ... yay):
vi /etc/X11/Xorg.conf to use the vesa driver.

then you can startup your gui by:
startx

That should do the trick for ya. I noticed most times the proprietary nvidia drivers fail is due to the kmod not being present for your running kernel. Check to see if the prior kernel works out ok for ya. Otherwise you can follow leigh123linux's nvidia driver guide to get the drivers back up and rockin some pixels.

lambcutlet
9th October 2010, 08:46 AM
yeah, i tried the 'ctrl + alt + f2'
the image on the display did not change.
tried various changes to xorg.conf via ssh and managed to change the image a few times.
i also ran 'init 3' via ssh and gained a commandline on the affected pc.

the only thing that resolved my problem was re-entering the automatic login settings in the /etc/gdm/custom.conf' file, which some how disappeared.

thats why i mentioned previously that i was stunned.

i have since loaded nvidia drivers and all is returned to normal.
thankyou for assisting