PDA

View Full Version : Display



ihateyou
24th September 2010, 06:26 AM
Hi,

I have no display after attempting nvidia driver install and doing telinit 3

On hitting F2 I get these errors -


checking for modules nvidia.ko [Failed]
nvidia.ko for kernel 2.6.33.3-85.fc13.x86_64 was not found [Warning]
The nvidia driver will not be enabled until one is found [Warning]

Is there anyway to boot in safe mode. I boot Fedora with GRUB2 and there isnt any failsafe entry for it. I have blacklisted nv driver already. Let me know how to boot console and fix this.

Best,

David

ozjd
24th September 2010, 08:19 AM
Blacklisting nv won't help as it isn't part of F13. Nouveau is the default driver for nvidia.

For the full process of installing nvidia drivers have a look at Leigh's thread, link in my signature.

ihateyou
24th September 2010, 12:45 PM
Well I followed that guide only. My immediate concern is to get x working or at least terminal log in, someone please help.

---------- Post added at 03:35 AM CDT ---------- Previous post was at 02:28 AM CDT ----------

Got the display back with DVD repair option, how do i check if i am using nvidia or not. the graphics look better now, trying to make sure i am doing it right.

---------- Post added at 03:45 AM CDT ---------- Previous post was at 03:35 AM CDT ----------

Got it working now. nv driver is a mean bugger.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 256.53 (mockbuild@hephaestus.wilsonet.com) Mon Sep 6 19:14:45 EDT 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 256.53 (mockbuild@) Mon Sep 6 18:28:07 EDT 2010
# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer AL1716W"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7025 / nForce 630a"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
Monitor "Monitor0"
SubSection "Display"
Modes "nvidia-auto-select"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


had to do sudo nvidia-settings for saving nvidia's xorg.conf