PDA

View Full Version : microphone is not responding for sphinx (speech recognition)



danfe
21st September 2010, 07:59 AM
Hi,

I have installed Fedora 11 recently on a new system. Sphinx speech recognition was working fine on my old system. When i run the same project on my new system, the system does not respond as it is waiting for microphone voice input.

Then I checked the microphone and have set it properly and its working now. The details how i made my microphone working is at the following link:

http://forums.fedoraforum.org/showpost.php?p=1400649&postcount=18

Though, I can record and play any sound, but it is not working with sphinx project. Please help me in this regard.

---------- Post added at 12:29 PM CDT ---------- Previous post was at 12:27 PM CDT ----------

Details of following link posted here...

http://forums.fedoraforum.org/showpost.php?p=1400649&postcount=18



[root@amit ~]# uname -r
2.6.30.10-105.2.23.fc11.i686.PAE


[root@amit ~]# lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)


[root@amit ~]# lspci -s 00:1b.0 -vn
00:1b.0 0403: 8086:293e (rev 02)
Subsystem: 1043:8277
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at fe970000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [130] Root Complex Link
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel


[root@amit ~]# lspci -v | grep -A+7 Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. Device 8277
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at fe970000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel



[root@amit ~]# cat /proc/asound/card?/codec#? | grep Codec
Codec: Realtek ALC883



[root@amit alsa]# rpm -qa | grep alsa
alsa-lib-devel-1.0.23-1.fc11.i586
alsa-utils-1.0.22-1.fc11.i586
alsa-plugins-jack-1.0.22-1.fc11.i586
alsa-lib-1.0.23-1.fc11.i586



[root@amit alsa]# rpm -qa| grep pulseaudio
pulseaudio-utils-0.9.15-17.fc11.i586
pulseaudio-libs-0.9.15-17.fc11.i586
pulseaudio-libs-glib2-0.9.15-17.fc11.i586
xine-lib-pulseaudio-1.1.16.3-2.fc11.i586



[root@amit modprobe.d]# cat /etc/asound.conf
#
# Place your global alsa-lib configuration here...
#

@hooks [
{
func load
files [
"/etc/alsa/pulse-default.conf"
]
errors false
}
]


** pulse-default.conf file is not present
[root@amit ~]# ls /etc/alsa/pulse-default.conf
ls: cannot access /etc/alsa/pulse-default.conf: No such file or directory


[root@amit modprobe.d]# cat /etc/alsa/pcm/jack.conf
# The jack plugin configuration
# $Id$

pcm.jack {
type jack
playback_ports {
0 alsa_pcm:playback_1
1 alsa_pcm:playback_2
}
capture_ports {
0 alsa_pcm:capture_1
1 alsa_pcm:capture_2
}
hint {
description "JACK Audio Connection Kit"
}
}


** ~/.asoundrc file is not present for user nor for root
[think@amit ~]$ cat ~/.asoundrc
cat: /home/think/.asoundrc: No such file or directory
[root@amit ~]# cat ~/.asoundrc
cat: /root/.asoundrc: No such file or directory


*** I didn't create any of the missing files. But followed the following steps to fix sound problem.

** back audio jack was not working, so changed to fromt audio jack (both playback and capture) and ran the 'amixer' command. It can be also done by with alsamixer to set audio mixser properties using arrow keys.

[root@amit etc]# amixer -c0 sset 'Input Source' 'Front Mic'

[root@amit etc]# alsamixer


*** I was able to record voice...

[root@amit ~]# arecord -r44100 -c 2 -t wav -f S16_LE output.wav
Recording WAVE 'output.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
^CAborted by signal Interrupt...


*** I was able to play it and hear it. There are many sound files located at '/usr/share/sounds/', one can try playing these as well.
[root@amit ~]# play output.wav

output.wav:

Encoding: Signed PCM
Channels: 2 @ 16-bit
Samplerate: 44100Hz
Replaygain: off
Duration: 00:00:06.20

In:100% 00:00:06.20 [00:00:00.00] Out:298k [-=====|===- ] Hd:1.4 Clip:542
play effects: rate clipped 253 samples; decrease volume?
play sox: alsa: output clipped 289 samples; decrease volume?
Done.