PDA

View Full Version : update to rawhide issues



Piscium
19th September 2010, 09:49 AM
Today I tried rawhide for the first time. On a separate partition I started with a fresh install of F13, then upgraded with yum per the wiki (though needed to skip broken).

While I can boot I have a number of issues. But starting with the first...



Error: Package: gnome-panel-2.31.90-1.fc15.i686 (rawhide)
Requires: libedataserverui-1.2.so.10

Any idea where I can get libedataserverui?

This problem - I guess - is causing me issues with the panel (because I am still using the F13 panel), like the keyboard is very slow for several minutes, but then starts working. And the terminal crashes at startup. (I can get a shell and use yum with CTRL-ALT Fx).

---------- Post added 2010-09-19 at 12:36 AM CDT ---------- Previous post was 2010-09-18 at 10:28 PM CDT ----------

I made some progress. I uninstalled a number of packages that were causing problems (I think there were some circular dependencies). Among them was evolution-data-server. To remove that a good chunk of Gnome had to be removed so I installed XFCE to have a graphical environment. I still cannot install Gnome but I will leave that for later.

I have some issues with systemd that is conflicting with upstart. I tried to remove upstart but that would cause hundreds of packages to be removed. Ideally I would like to have both upstart and systemd installed so that I could boot one or the other by entering a parameter in grub.

Does anybody know how to solve this issue below?


[root@dell-d3000 ~]# yum update
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package initscripts.i686 0:9.21-2.fc15 set to be updated
---> Package system-setup-keyboard.i686 0:0.8.6-1.fc15 set to be updated
--> Processing Dependency: systemd for package: system-setup-keyboard-0.8.6-1.fc15.i686
---> Package systemd-sysvinit.i686 0:10-3.fc15 set to be installed
--> Processing Dependency: upstart for package: 1:readahead-1.5.7-1.fc15.i686
--> Processing Dependency: upstart = 0.6.5-8.fc15 for package: upstart-sysvinit-0.6.5-8.fc15.i686
--> Running transaction check
---> Package systemd.i686 0:10-3.fc15 set to be installed
--> Processing Dependency: upstart for package: 1:readahead-1.5.7-1.fc15.i686
--> Processing Dependency: upstart = 0.6.5-8.fc15 for package: upstart-sysvinit-0.6.5-8.fc15.i686
--> Processing Conflict: upstart-sysvinit-0.6.5-8.fc15.i686 conflicts systemd-sysvinit
--> Processing Conflict: systemd-sysvinit-10-3.fc15.i686 conflicts upstart-sysvinit
--> Finished Dependency Resolution
Error: Package: upstart-sysvinit-0.6.5-8.fc15.i686 (@rawhide/13)
Requires: upstart = 0.6.5-8.fc15
Removing: upstart-0.6.5-8.fc15.i686 (@rawhide/13)
upstart = 0.6.5-8.fc15
Obsoleted By: systemd-sysvinit-10-3.fc15.i686 (rawhide)
Not found
Error: systemd-sysvinit conflicts with upstart-sysvinit
Error: upstart-sysvinit conflicts with systemd-sysvinit
Error: Package: 1:readahead-1.5.7-1.fc15.i686 (@rawhide)
Requires: upstart
Removing: upstart-0.6.5-8.fc15.i686 (@rawhide/13)
upstart = 0.6.5-8.fc15
Obsoleted By: systemd-sysvinit-10-3.fc15.i686 (rawhide)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

---------- Post added at 09:49 AM CDT ---------- Previous post was at 12:36 AM CDT ----------

I managed to solve the yum conflict between upstart and systemd by using the yum shell to remove upstart and install systemd. So all was neatly installed, and "yum update" showed no more updates available.

But then when I entered "reboot" after yum shell, it didn't reboot, it said it could not talk to init or something like that. So I switched off the computer.

The problem now is that boot takes forever, like, 5 minutes. It gets stuck in different places. The first stumbling block is "Starts the Name Switch Cache Daemon Failed".

And the dbus daemon seems to be doing a lot of something - not sure what. This is not systemd related because it also happened with upstart.

Well, that is enough rawhide for today, I will try again some other day.

kurtdriver
19th September 2010, 01:55 PM
I'm not sure how you did the upgrade to rawhide, but you had to skip the broken packages at the time, and that doesn't sound good. The one buggy rawhide install I've had was one that had a lot of broken packages during the actual upgrade, before rebooting to the new kernel. Other than that, I haven't had these issues. Maybe it's best to start over? Do you want a working computer or a learning experience? Have you tried
yum provides */libedataserverui

Piscium
19th September 2010, 10:42 PM
I installed rawhide like this: on a separate partition I started with a fresh install of F13, then upgraded with

1. Type: yum install fedora-release-rawhide
2. Then type: yum --disablerepo=* --enablerepo=rawhide update

as it says here:
http://fedoraproject.org/wiki/Releases/Rawhide

except that as I said I had to skip-broken.

Basically there were two sets of broken packages. The first set had to do with the conflict upstart vs. rawhide:

--> Processing Conflict: upstart-sysvinit-0.6.5-8.fc15.i686 conflicts systemd-sysvinit
--> Processing Conflict: systemd-sysvinit-10-3.fc15.i686 conflicts upstart-sysvinit

This means that you cannot have both installed simultaneously.

The other conflict was with Gnome packages. I did "yum provides" and found out that evolution-data-server-devel provides libedataserverui-1.2.so. But I installed the former and did not solve the issue. But there are a few more Gnome issues. This is what I get when I attempt a groupinstall of Gnome desktop:


Error: Package: seahorse-2.31.91-1.fc15.i686 (rawhide)
Requires: libgcr.so.0
Error: Package: 1:gnome-bluetooth-2.90.0-5.fc15.i686 (rawhide)
Requires: libgnome-control-center.so.1
Error: Package: gnome-shell-2.31.5-5.fc14.i686 (rawhide)
Requires: libmozjs.so
Error: Package: vpnc-0.5.3-7.fc13.i686 (rawhide)
Requires: upstart >= 0.6.0
Available: upstart-0.6.5-8.fc15.i686 (rawhide)
upstart = 0.6.5-8.fc15
Error: Package: gnome-media-2.31.5-5.fc15.i686 (rawhide)
Requires: libgnome-control-center.so.1
Error: Package: gnome-panel-2.31.90-1.fc15.i686 (rawhide)
Requires: libedataserverui-1.2.so.10
Error: Package: gjs-0.7.1-3.fc14.i686 (rawhide)
Requires: libmozjs.so

So at the moment I have no Gnome and instead have installed XFCE and LXDE.

I would say this is just a blip and will likely disappear in a few days.

---------- Post added at 10:42 PM CDT ---------- Previous post was at 04:16 PM CDT ----------

Found out that most of the broken dependencies that I encountered are in this automated email, for example seahorse:
http://www.spinics.net/lists/fedora-devel/msg143016.html

But vpnc requiring upstart looks like a package issue (and it is not listed on the above email).