PDA

View Full Version : installing deja-dup in fedora 12



p4rk3r
17th September 2010, 04:21 PM
Hi every one, i want to install deja-dup 14.2
when i configure it, i found eror

here is the eror when i configure it

[root@harry deja-dup-14.2]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether ln -s works... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking gnome-doc-utils >= 0.3.2... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking whether make sets $(MAKE)... (cached) yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking the maximum length of command line arguments... 1966080
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... no
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for gconftool-2... /usr/bin/gconftool-2
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
checking for po4a... no
checking for valac... no
configure: WARNING: Vala compilation is disabled.
checking whether NLS is requested... yes
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for shared library run path origin... done
checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking for GNU gettext in libc... yes
checking whether to use NLS... yes
checking where the gettext function comes from... libc
checking for intltool >= 0.40... 0.41.0 found
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... (cached) /usr/bin/xgettext
checking for msgmerge... (cached) /usr/bin/msgmerge
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.0
checking for XML::Parser... ok
checking for DUP... yes
checking for PREF... configure: error: Package requirements (gtk+-2.0 >= 2.18
gio-2.0 >= 2.20
gconf-2.0
unique-1.0) were not met:

No package 'unique-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PREF_CFLAGS
and PREF_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
[root@harry deja-dup-14.2]#

can every one explain to me, what should i do ?

thank you very much :)

PabloTwo
17th September 2010, 06:54 PM
There are a few packages you would need to install in order to compile deja-dup-14.2, and it would be doable. But, for F12, the much easier way is to download and install the F13 package of deja-dup-14.2. I just did this to see if was doable. Yes, it is.

wget -c http://kojipkgs.fedoraproject.org/packages/deja-dup/14.2/2.fc13/i686/deja-dup-14.2-2.fc13.i686.rpm
sudo yum --nogpgcheck localinstall deja-dup-14.2-2.fc13.i686.rpm
Loaded plugins: presto
Setting up Local Package Process
Examining deja-dup-14.2-2.fc13.i686.rpm: deja-dup-14.2-2.fc13.i686
Marking deja-dup-14.2-2.fc13.i686.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package deja-dup.i686 0:14.2-2.fc13 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ================================================== =========================
Package Arch Version Repository Size
================================================== ================================================== =========================
Installing:
deja-dup i686 14.2-2.fc13 /deja-dup-14.2-2.fc13.i686 1.5 M

Transaction Summary
================================================== ================================================== =========================
Install 1 Package(s)

Total size: 1.5 M
Installed size: 1.5 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : deja-dup-14.2-2.fc13.i686 1/1

Installed:
deja-dup.i686 0:14.2-2.fc13

Complete!
Attempting to install the deja-dup package downloaded from another site resulted in missing dependency "duplicity", which I yum installed from the F12 repos (it dragged in another 4 packages for it's dependencies), but that package had an error with a corrupt file so I deleted it and grabbed the package from koji.

If you are using 64bit F12, just substitute the "i686" in the download url with "x86_64" to get the correct package to install.

JValeck
22nd May 2011, 09:38 PM
Hi PabloTwo,
I tried the above to install the x86_64 version which seemed to go well. Under Applications/System Tools I have a listing for Deja-dup Backup Tool. When I run it I get the initial Restore and Backup selections but if I click on the backup it just disappears then nothing. I also tried to select Preferences with no response.

I just noticed the date of this post. Perhaps I am using an old version of the program.

Any suggestions?

Thanks,
Val

RahulSundaram
23rd May 2011, 12:41 AM
Hi

I maintain Deja-dup for Fedora. Newer versions of Deja-dup have fixed a number of important bugs and I don't recommend using older versions but getting the newer version to build on Fedora 12 would be difficult due to the dependencies. Fedora 12 has already reached EOL and does not even receive security updates anymore and Fedora 13 is about to reach EOL as well. I recommend using Fedora 14 or Fedora 15 (about to be released in a couple of days) if you want to use deja-dup.

tox
23rd May 2011, 12:53 AM
Fedora14 would be a better bet to use atm.. IMO

---------- Post added at 09:53 AM ---------- Previous post was at 09:51 AM ----------

unless youj get the source of Rahuls updated versions and compile them for f12 an get the deps