PDA

View Full Version : How To Upgrade to KDE 4.5.1



jasbutut
16th September 2010, 06:51 PM
Hi!

I currently use KDE 4.4.5 and want to upgrade it to 4.5.1

How is the easiest way to doing that with fedora 13?

This is my 2nd day using Fedora and KDE and I'm happy :D

Note: Damn! I forgot question mark for the title! Sorry...

steelaworkn
16th September 2010, 07:46 PM
It's not actually easy. But you can go here (http://forums.fedoraforum.org/showthread.php?t=250066)

You should be able to install it from there. I'm just waiting until it comes out in the Fedora repos. That might actually be in F14 or at least at the tail-end of F13's run.

jasbutut
16th September 2010, 08:23 PM
It's not actually easy. But you can go here (http://forums.fedoraforum.org/showthread.php?t=250066)

You should be able to install it from there. I'm just waiting until it comes out in the Fedora repos. That might actually be in F14 or at least at the tail-end of F13's run.

Thanks for the link. :)

I'll try it if it's not to hard for a noob like me :D

ozjd
16th September 2010, 11:40 PM
Thanks for the link. :)

I'll try it if it's not to hard for a noob like me :D

Post 5 in that thread is the one to follow. Just a couple of commands, very simple.

jasbutut
17th September 2010, 07:47 AM
Post 5 in that thread is the one to follow. Just a couple of commands, very simple.

I've tried that but got this error:


Error: Package: 6:kdepim-4.4.93-2.fc13.x86_64 (kde-unstable)
Requires: libkcmutils.so.4()(64bit)
Error: Package: kdepim-runtime-libs-4.4.93-1.fc13.x86_64 (kde-unstable)
Requires: kdepimlibs-akonadi(x86-64) >= 4.5.1
Installed: kdepimlibs-akonadi-4.4.5-1.fc13.x86_64 (@updates)
kdepimlibs-akonadi(x86-64) = 4.4.5-1.fc13
Available: kdepimlibs-akonadi-4.4.2-1.fc13.x86_64 (fedora)
kdepimlibs-akonadi(x86-64) = 4.4.2-1.fc13
Error: Package: 6:kdepim-4.4.93-2.fc13.x86_64 (kde-unstable)
Requires: kdebase-runtime >= 4.5.1
Installed: kdebase-runtime-4.4.5-1.fc13.x86_64 (@updates)
kdebase-runtime = 4.4.5-1.fc13
Available: kdebase-runtime-4.4.2-3.fc13.x86_64 (fedora)
kdebase-runtime = 4.4.2-3.fc13
Error: Package: 6:kdepim-libs-4.4.93-2.fc13.x86_64 (kde-unstable)
Requires: libkprintutils.so.4()(64bit)
Error: Package: kdepim-runtime-libs-4.4.93-1.fc13.x86_64 (kde-unstable)
Requires: akonadi(x86-64) >= 1.4.0
Installed: akonadi-1.3.1-4.fc13.x86_64 (@released/$releasever)
akonadi(x86-64) = 1.3.1-4.fc13
Error: Package: kdepim-runtime-4.4.93-1.fc13.x86_64 (kde-unstable)
Requires: libkcmutils.so.4()(64bit)
Error: Package: 6:kdepim-libs-4.4.93-2.fc13.x86_64 (kde-unstable)
Requires: libkcmutils.so.4()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Any suggestions?

leigh123linux
17th September 2010, 09:01 AM
Try



yum update @kde --enablerepo=kde*,u*g --disablerepo=kde-unstable