PDA

View Full Version : Probably permission problem of xmms



cyriver
20th October 2004, 01:37 AM
I'm using Fedora Core2. I can listen mp3 music using xmms or rhythmbox as a root.
But as a normal user, both program doesn't seem to work properly. xmms does not produce any sound and rhythmbox gives an error message, "could not pause playback".

The latter problem was posted in buglist and I tried to follow the resolution with no vain.

For me, it seems a permission problem but don't know how to solve.

Any hint will be appreciated.

venson
20th October 2004, 11:24 PM
Try launching XMMS from the commandline. See if there's any errors messages output.

Also, can you hear any sounds at all in user space? If you don't, perhaps you need to check the permissions on your /dev/dsp device. It looks hence on my computer.

lrwxrwxrwx 1 root root 9 Mar 23 2004 /dev/dsp -> /dev/dsp0

Try those two things and get back to us here.

cyriver
21st October 2004, 03:14 AM
Hi venson,
Thanks for reply.
But the problem was not related to permission at all. It was due to my stupid mistake.

For the xmms problem, just after I added playlist, I moved those mp3 files to other folder.
So, surely there will be no sound.
When I checked as root, I added files with the right folder, so there should be a sound.
Now as user, I have no problem with the xmms since the playlist are added through the right folder. ^.^

For the rhythmbox prlblem, I read
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119958
and as suggested, I ran the command
,gconftool-2 -s /system/gstreamer/0.8/default/audiosink -t string "alsasink device=hw:0",
as root. After that, the rhythmbox worked fine as root. But still no sound as user.

Finally, I ran the above command as user as well and the rhythmbox also worked fine as user.

It turned out that my post is just a happening. ^.^

imdeemvp
21st October 2004, 04:24 AM
It turned out that my post is just a happening. ^.^
this may help others in the future....so its always good to know, and if you music folder is set with root privilages you can change to you by using the chown (change ownership) command.