PDA

View Full Version : gnome breaks dvd player?



tparker
7th September 2010, 08:35 PM
I'm having a very odd and frustrating problem that I have been trying to solve for months and can't seem to track down. If gnome (pretty much anything gnome/gtk) is installed on my system then the DVD/CDrom drive can't be used. The computer can sometimes see the drive and sometimes not see it, can sometimes mount it but not other times. Video players (xine, mplayer, etc.) can sometimes see a disk (even if the rest of the system can't) but not consistently and if they start playing a disk it will work fine for a while and then they magically can't find it anymore.

background: The first time this happened (back in Fedora 11, both 32 and 64 bit) and I couldn't track it down I assumed a bad DVD drive and replaced it, but that did not fix the problem. It also happened in Fedora 12, but -not- in the Fedora 12KDE spin as long as I kept it gnome free. When I tried a yum update from 12KDE to 13KDE I messed something up and got regular Fedora 13 iinstead of the spin and the drive stopped working again. I gave up and did a gentoo install with -gnome and -gtk USE flags and the drive worked fine. For unrelated reasons I ended up back in Fedora (64 bit, xfce spin) a couple days ago and the problem is back. I can't even eject the drive to get a disk out once I've tried to play one unless I use a paperclip to pop it open.

I haven't found anything related to this to try via forum/google search. Any ideas where I start to track this down?