View Full Version : Help me upgrading Firefox 3.6.7 to 3.6.8 in FC13

6th September 2010, 09:29 PM

I need help upgrading from Firefox 3.6.7 to 3.6.8. I downloaded the new version 3.6.8 from mozilla.org into /home/user/Downloads, cd to that directory then followed the instruction from Pablo Two:

tar xjvf firefox-3.6.8.tar.bz2 -C /opt

cd /usr/bin
mv firefox firefox-3.6.7.sh
ln -s /opt/firefox/firefox

When I clicked on the Firefox icon, the browser does not load!

Looking into /usr/bin, I saw 3 files:

firefox (with an arrow pointing down to the right), firefox-3.6.7.sh (also with same arrow) and firefox-3.6.8.sh (without arrow).

Could you help me sort out this problem? I must have made a mistake somewhere. Thanks a lot!


---------- Post added at 04:29 PM CDT ---------- Previous post was at 12:33 PM CDT ----------


Became root and changed permission to give execution permission before I can delete firefox-3.6.8.sh in /usr/bin.

Browser still didn't load so I had to uninstall and re-install firefox. Now I can load firefox 3.6.7!!!!

I think there could be an error and a contradiction in the following 2 lines, respectively:

mv firefox firefox-3.6.7.sh
(Shouldn't it be: mv oldfirefox newfirefox.sh, where oldfirefox=3.6.7and newfirefox=3.6.8?)

ln -s /opt/firefox/firefox
(Shouldn't this be: ln -s /opt/firefox/firefox-3.6.8.sh?)

Any suggestions?


7th September 2010, 02:48 AM
Hello tayton888,

The original /usr/bin/firefox file that is installed from the Fedora repository is a shell script, which will eventually call /usr/lib/firefox-<version>/firefox. If you don't plan on running v 3.6.7 any longer, it's not really necessary at all to preserve that file by renaming it. I only suggested that should the user decide to "mv" it back to it's original name "firefox" for later use. Renaming the original /usr/bin/firefox to /usr/bin/firefox-3.6.7.sh means it will no longer be used.

You do not want to create a symlink to /opt/firefox/firefox-3.6.8.sh as that file does not exist.

Creating the symlink /usr/bin/firefox that points to /opt/firefox/firefox is correct.

If the icon you click on is still bringing up FF 3.6.7, then you need to look at the properties of that icon launcher and perhaps change what it is executing. Try right clicking on it the icon, and if there is a "properties" menu item, click on it and see what "command" is being executed. Changing it to just "firefox" will launch FF 3.6.8 if you properly created the symlink in /usr/bin/. You need to be in the directory /usr/bin/ when you issue, as root, the command below

ln -s /opt/firefox/firefox

You can create the symlink without being in the directory /usr/bin/ by using

ls -s /opt/firefox/firefox /usr/bin/

7th September 2010, 03:44 AM
Hello PabloTwo,

Thanks for your detailed explanation.

# cd /usr/bin

# ln -s /opt/firefox/firefox
ln: creating symbolic link `./firefox': File exists

When I hit FF icon on the taskbar, version 3.6.7 still shows up. Right-clicking the icon > Properties > Command shows "firefox %u".

After deleting %u from the command and restarting Firefox, I still get the old version 3.6.7! I suspect that after reinstalling Firefox previously, the new version 3.6.8 in /opt was replaced with the old version 3.6.7.

1) Is there a way to confirm the current version of firefox in /opt?

2) Is there a way to delete "firefox" (with a lock sign) in ~/Downloads, so that I can extract "firefox-3.6.8.tar.bz2" also in Downloads, to start over?

Thanks a lot for your help.

7th September 2010, 04:02 AM
Try creating the link in /usr/local/bin

That will be ahead of /usr/bin in your PATH and should find the new firefox

7th September 2010, 04:25 AM
probably a waste of time installing 3.6.8 when 3.6.9 will be released tomorrow

---------- Post added at 01:25 PM CDT ---------- Previous post was at 01:24 PM CDT ----------


7th September 2010, 08:46 PM
Please post the output from these commands,

ls -l /usr/bin/firefox
ls -l /usr/local/bin/firefox
After making sure all instances of FF are closed, in a terminal, run this command,

When FF runs using the above command, click on the "Help" item in the FF tool bar and then click on "About Mozilla Firefox" to see which version is running.

You could also check just by doing, in a terminal,

/opt/firefox/firefox -version

8th September 2010, 02:22 AM
Hi PabloTwo,

I opened up the terminal before launching Firefox:

# ls -l /usr/bin/firefox
-rwxr-xr-x. 1 root root 7778 Jul 20 13:16 /usr/bin/firefox

# ls -l /usr/local/bin/firefox
ls: cannot access /usr/local/bin/firefox: No such file or directory

I got the following before AND after opening up the browser:

# /opt/firefox/firefox
/opt/firefox/firefox-bin: error while loading shared libraries: /opt/firefox/libxul.so: cannot restore segment prot after reloc: Permission denied

I can confirm that the current version of FF is 3.6.7, via Help > About. I also want to add that since yesterday there has been no swirling orb when I hit the Firefox icon on the toolbar. The browser just loads almost right away.

---------- Post added at 09:22 PM CDT ---------- Previous post was at 05:11 PM CDT ----------


Just downloaded and saved firefox-3.6.9.tar.bz2 from Mozilla.org.


8th September 2010, 02:53 PM
Your /usr/bin/firefox file is the shell script installed by FF 3.6.7 which will launch FF 3.6.7.

My original instruction was to change into the directory /usr/bin, and as root rename that file so that it would no longer be active and create a symbolic with the name "firefox" to replace it that would link to /opt/firefox/firefox. Your current setup as described above does neither.

More importantly at the moment though is to understand why and how to fix the issue you are having with trying to run the version of FF in /opt/, whether it be 3.6.8 or 3.6.9. Since I run F12 and don't have that issue with the /opt/firefox/libxul.so permission I'm not sure how to fix that. You could first try switching to root then running the command /opt/firefox/firefox to see if you get the same (or different) error.

You could see if it's an SELinux problem by temporarily setting SELinux to Permissive mode with, as root, setenfoce 0.
Restore to Enforcing mode with setenforce 1.
It also wouldn't hurt to make sure you have xulrunner updated, as it also installs a libxul.so file, though I don't think that's the probem. On my system,

BASH:~/-> locate libxul.so

If it's an SELinux problem (more likely), you may need to alter one or two SELinux policy booleans. The most likely suspects being,

BASH:~/-> getsebool -a | grep allow_exec
allow_execheap --> off
allow_execmem --> on
allow_execmod --> on
allow_execstack --> on
All three of the items above turned on I did myself in order to allow various software to run. You can toggle those on (allow) or off (disallow)
using the setsebool command, such as: setsebool -P allow_execmod 1 (where 0=off and 1=on). You can check the current status
using the getsebool command, such as: getsebool allow_execmod