View Full Version : Where is the partitioner?

29th August 2010, 05:34 PM
I've tried installing F-14 with the BFO and DVD [bittorrent download]. When I get to what I expect to be the partitioning step it offers only 3 options:

1. Use entire disk
2. Replace installed system
3. Use Free space

I select 2>OK and it goes directly to 'Write changes to disk'. The problem with that is that the selected drive looks like this:

# fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002e10d

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2039 16378236 83 Linux
/dev/sda2 2040 5992 31744000 83 Linux
/dev/sda3 5992 6514 4200825 82 Linux swap / Solaris
/dev/sda4 6515 121601 924436297 5 Extended
/dev/sda5 6515 8554 16386268+ 83 Linux
/dev/sda6 8555 12506 31744408+ 83 Linux
/dev/sda7 12507 14546 16386268+ 83 Linux
/dev/sda8 14547 18498 31744408+ 83 Linux
/dev/sda9 18499 20538 16386268+ 83 Linux
/dev/sda10 20539 24618 32772568+ 83 Linux
/dev/sda11 24619 26658 16386268+ 83 Linux
/dev/sda12 26659 30738 32772568+ 83 Linux
/dev/sda13 30739 32778 16386268+ 83 Linux
/dev/sda14 32779 36858 32772568+ 83 Linux
/dev/sda15 55821 121601 528385851 83 Linux

So I was expecting an opportunity to select specific partitions. I have no idea what changes it was prepared to write so I had to abort installation. What gives???

The second error is if I select 3 'Use free space' it returns error 'not enough free space' even though there is over 160 GB of free space. Again what gives?

---------- Post added at 11:03 AM CDT ---------- Previous post was at 10:54 AM CDT ----------

Not sure if I'm doing this right:

# sha256sum Fedora-14-Alpha-x86_64-DVD.iso
e478eba44f471dc7af4cb89dfe62dc73758ad50481b2faa3cd 44a066309e67fd Fedora-14-Alpha-x86_64-DVD.iso

# sha256sum bfo.iso
75149b385ea9445327ede72631e6469dc41ff00cdd27b7926d c783b46089cfb4 bfo.iso

---------- Post added at 11:34 AM CDT ---------- Previous post was at 11:03 AM CDT ----------

The DVD checksum does match the checksum provided here:


So my next question is the missing partitioner a bug?

29th August 2010, 05:54 PM
If the checksums don't match you got a buggy download. There can also be errors in burning, so you should do the check at the bootime of the DVD as this will detect burn errors. Did you download a torrent? There shouldn't be download errors with a torrent as they include error checking.

29th August 2010, 05:56 PM
Are you sure you didn't see something for custom partitioning? You might have to click an arrow somewhere to get to that option.

However, I haven't tried installing F14 yet, so it's quite possible there's a bug in it. (On the other hand, I haven't seen mention of this on the testing list). Or, of course, it could be that just because it's still alpha, it's not yet complete.

29th August 2010, 06:13 PM
The DVD checksum does match the checksum provided here...Yes it does.# sha256sum Fedora-14-Alpha-x86_64-DVD.iso
e478eba44f471dc7af4cb89dfe62dc73758ad50481b2faa3cd 44a066309e67fd Fedora-14-Alpha-x86_64-DVD-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

# The image checksum(s) are generated with sha256sum.
e478eba44f471dc7af4cb89dfe62dc73758ad50481b2faa3cd 44a066309e67fd *Fedora-14-Alpha-x86_64-DVD.iso
774f6b90421974322df556a172da40ebb8b7ab44c7b5c8db3f 290e11b36172b7 *Fedora-14-Alpha-x86_64-disc1.iso
846d12274a2949f88d3eb0b2e01b3de27576cd74c35a29709d 9638f7098e01a7 *Fedora-14-Alpha-x86_64-disc2.iso
94e5854772a36dd32807353c14a4df44e814cd47e1f69511e8 b5a0fa56ebddc4 *Fedora-14-Alpha-x86_64-disc3.iso
6a04b68dd94303301f344119900cdbbbe9457237a4b8ed17b8 7b0e92c75f2b3e *Fedora-14-Alpha-x86_64-disc4.iso
02ba6389fd6bee706027e168ef5d9afe80f01c97bd343d3ba6 1dabdde4864c2e *Fedora-14-Alpha-x86_64-disc5.iso
9fabb4b188dca83fe0b3cb6d003d4d8c8ccadfc0ba9c7387cd 3688b7da6f03ca *Fedora-14-Alpha-x86_64-netinst.iso

The second error is if I select 3 'Use free space' it returns error 'not enough free space' even though there is over 160 GB of free space. Again what gives?True, there is some space available in cylinders 36859 to 55821. Maybe the issue is that you already have fifteen partitions. That's the max for the libata driver code nowadays.

29th August 2010, 06:14 PM
Ok, I just downloaded disk one of the alpha. At the bottom, there was definitely an option for Custom partitioning.

I see they've also, at the place where you give the host name, given an option to configure networking, which is an important improvement IMNSHO.

29th August 2010, 07:43 PM
Uh, I'm feeling kinda stupid right now. It's because the installer was in text mode and I was dumb enough not to notice... However that may be a problem for people that actually want to install in text mode.

I had to select to 'Install with basic video driver' because Fedora installer doesn't work with my graphics [onboard ASUS M2NPV-VM];

$ lspci
00:05.0 VGA compatible controller: nVidia Corporation C51PV [GeForce 6150] (rev a2)

and then the partitioner allowed me to select 'Custom Partitioning'. My graphics will work with nouveau but rarely do with nv. Anyway problem solved.

30th August 2010, 12:09 AM
No, you shouldn't feel stupid. They crippled text mode--one of my pet peeves, actually, especially as RH has the gall to call it "simplified and streamlined." I feel calling it that is on the level of the one who decided on the name Windows Genuine Advantage. :)

Yes textmode can only be customized with kickstart now. There's some other things left out of it, I've forgotten what they were, possibly package selection. However, though I enjoy ranting about it, it seems that very few people care.

In theory, using the vesa driver, if nothing else works, any machine can be installed in text mode. In practice, there can be some problems--but mostly, I've seen them on the Fedora-testing list, and they're usually worked out by the time it hits beta. (Such as various cards not even working with vesa, or, on netbooks, the various boxes that you have to click being off screen. However, it seems that this is usually fixed by beta.)

Grouch, grouch, in many ways, every time they leave another text tool behind for a gui, it bothers me. As stevea has pointed out in other threads, however, I do tend to exaggerate.

Still, it's something that has lost features, which I think could be called a regression. :D

---------- Post added at 07:09 PM CDT ---------- Previous post was at 03:38 PM CDT ----------

As one example, F14 alpha won't install in VirtualBox. You get a black screen. Bug has been filed, and it will probably be fixed by alpha, but, of course textmode is fine, but of course, it's crippled. And folks wonder why I'm such a grouch. (It did work fine in qemu though.)