PDA

View Full Version : Conky hides my gnome-panel



st0kes
26th August 2010, 08:20 PM
I would like to run Conky on my Gnome desktop, I've configured a .conkyrc and it works quite nicely if I launch it in a terminal.

However .... if I set it to run as a startup application (by using /usr/bin/conky &), 2 unexpected things happen.

1. Conky doesn't load
2. My gnome-panel doesn't appear

However, gnome-panel is running, as I am unable to launch another one.

What's the correct way to launch Conky?

glennzo
26th August 2010, 08:56 PM
Just an idea. Not sure if it will solve you problem but it won't cost anything to try. Instead of launching conky directly with /usr/bin/conky & try doing what I've seen recommended and use myself. Create a .ck.sh file in your home folder with the following content

#!/bin/bash
sleep 15 && conky -q;
Save the file and make it executable with

chmod +x .ck.sh
Then add it to system > preferences > startup applications. See how that works on the next bootup.

st0kes
26th August 2010, 09:50 PM
That allows my gnome-panel to load but still no Conky!

It's a small step forward :p

glennzo
27th August 2010, 01:49 AM
Well, here's what I would do next. First, I'll claim that I'm not even close to a conky guru. That said, I would make a backup of my conky.conf. Then I would remove a few random lines from the top sections, ones that don't obviously (to me) need to be there. Then I would reload conky from the command line.

killall -SIGUSR1 conky
Wait for conky to reappear. If there is no change then put the lines you removed back in and remove a couple others. Repeat as necessary until problem solved. I refer to the conky documentation quite often also, http://conky.sourceforge.net/documentation.html, looking at the variables and config file settings. They've been very helpful to me.