PDA

View Full Version : How to shut off F13 spash screen to see messages?



recondite
26th August 2010, 02:03 AM
When I boot up or shut down F13 I see the blue splash screen with the fedora logo. How do I shut this off? It seems to be hiding those pretty boot-up and shut-down messages that reassure me my computer hasn't frozen up.

Dan
26th August 2010, 02:21 AM
Either press the [esc] key as soon as that screen shows up, or catch the boot in GRUB and remove the "rhgb" and "quiet" commands from the boot line.

Or, once you're booted up, run the following in a terminal:


su -
(provide root password)
gedit /boot/grub/grub.conf


When gedit has it open for you, delete "rhgb" and "quiet" from the boot line, save the file, close the document, close gedit, exit the root terminal, exit the user terminal ... and re-boot.

Unless something went drastically wrong, You should be right back to the comfy old dinosaur-style way of doing things. <..:p..>

recondite
26th August 2010, 04:59 AM
I made the changes in the grub.conf file and it did not work. Could it have something to do with not being on a dual-boot system? All I have on my disk is F13. I don't even see the grub menu when I boot up (never did on this system). So maybe it's not using grub at all?

---------- Post added at 07:48 PM CDT ---------- Previous post was at 07:32 PM CDT ----------

OK, now it works, after fixing an editing error.

---------- Post added at 07:59 PM CDT ---------- Previous post was at 07:48 PM CDT ----------

Any chance that change could have disabled assistive technologies? i.e. the dwell click feature?

smr54
26th August 2010, 05:41 AM
Hrrm.

You definitely removed the rhgb quiet from the end of the kernel line?
One possible explanation (not even sure about this though) is that if, while logged in, you updated and got a newer kernel, maybe the new kernel line still has the rhgb quiet, but it seems to me, if I remove it once, it stays removed.

If the line hidden says =1, i.e. hidden=1 change that to 0. Also the timeout is also set to 0 by default, change the default timeout from 0 to a number you prefer, e.g., 3, which will keep the grub menu on the screen for 3 seconds. (insert rant about changing it to 0 was stupid, as it's one of my pet minor peeves).

You might also (this is up to you) add at the end of the kernel line,

nomodeset

What this does is take away the frame buffer--what I see happen if this is not set is that first it will boot, I'll see the messages for a few seconds, then it goes black while it changes to framebuffer mode. The characters on the screen then appear in smaller, neater type.

If you do add in the nomodeset at the end of the kernel line, at some point, it might ask you to choose a mode, but you should be able to hit space to continue.

However, I'm a bit surprised that removing the rhgb quiet didn't do it. Double check that you saved the file, that is, rather than closing without saving.

Jamwa
26th August 2010, 06:31 AM
I think it may also benefit you to read this article (http://www.arthurbuliva.com/?q=node/12) and setting your theme to details

errorxp
26th August 2010, 09:31 AM
You can also use arrow up and arrow down buttons to change between the splash screen and boot messages.

stevea
26th August 2010, 10:06 AM
If you want to see the grub menu, then comment out the "hiddenmenu" in grub.conf and set the timeout to a reasonable number of seconds.

timeout=5
#hiddenmenu

Then I'll suggest you stop grub at bootup and edit to remove the "rhgb quiet".

As others have suggested, there are several kernel lines in the grub.conf and you'll either have to understand and select the correct one, or else remove the text from all. So editing from the grub boot menu is simpler and more direct I think.

bonedome
27th August 2010, 08:39 AM
Hello
I just press Esc when the blue screen starts