PDA

View Full Version : Unable to Install VLC on F13



shaolin
24th August 2010, 04:04 AM
Hello Everyone,
I've recently updated my box from Fedora 12 to Fedora 13....today I wanted to install VLC and followed the procedures provided on VideoLAN's website on how to install VLC (See Below):

Use RPM Fusion for F11, F12 and F13 (available for x86, x86_64, ppc and ppc64)
Install rpmfusion-free-release-stable.noarch.rpm for F11, F12 and F13.

$> su -
#> rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
#> yum install vlc
#> yum install mozilla-vlc (optionnal)


When attempting the second step:

rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm

I'm getting the following:

Retrieving http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
warning: /var/tmp/rpm-tmp.YutBY1: Header V3 RSA/SHA256 Signature, key ID 8fcff4da: NOKEY
Preparing... ########################################### [100%]
package rpmfusion-free-release-12-1.noarch (which is newer than rpmfusion-free-release-11-2.noarch) is already installed
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-latest-i386 from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-latest-ppc from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-latest-ppc64 from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-latest-x86_64 from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-rawhide-i386 from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-rawhide-ppc from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-rawhide-ppc64 from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-rawhide-x86_64 from install of rpmfusion-free-release-11-2.noarch conflicts with file from package rpmfusion-free-release-12-1.noarch


Please Help!!!!!

Hansvon
24th August 2010, 05:55 AM
You already have rpmfusion release rpm installed but it doesn't seem to be the good version (12, not 13). You should run "yum update" and then "yum install vlc".

marko
24th August 2010, 06:27 AM
Yeah, Hanson's right, after you do the rpmfusion install via the rpm command, usually you need to update rpmfusion again via yum. At that point, your Fedora 13 should have these rpmfusion packages

rpmfusion-free-release-13-2.noarch and rpmfusion-nonfree-release-13-2.noarch

shaolin
24th August 2010, 04:02 PM
I ran the command:

yum update

last night also and I get the following:

Loaded plugins: presto, refresh-packagekit
Setting up Update Process
No Packages marked for Update

---------- Post added at 10:02 AM CDT ---------- Previous post was at 08:53 AM CDT ----------

If this helps, I ran a repolist all command:

Loaded plugins: presto, refresh-packagekit
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated enabled: 18
fedora Fedora 13 - i386 enabled: 16,814
fedora-debuginfo Fedora 13 - i386 - Debug disabled
fedora-source Fedora 13 - Source disabled
updates Fedora 13 - i386 - Updates enabled: 4,827
updates-debuginfo Fedora 13 - i386 - Updates - Debug disabled
updates-source Fedora 13 - Updates Source disabled
updates-testing Fedora 13 - i386 - Test Updates disabled
updates-testing-debuginfo Fedora 13 - i386 - Test Updates Debug disabled
updates-testing-source Fedora 13 - Test Updates Source disabled
repolist: 21,659

Hansvon
24th August 2010, 11:13 PM
So, remove rpmfusion (yum remove rpmfusion*) and reinstall it (http://rpmfusion.org/Configuration). Between the two steps, maybe remove the repo file, if any (rm /etc/yum.repos.d/rpmfusion*) because something is wrong with them.