PDA

View Full Version : Services fail to start continuously



synops
22nd August 2010, 09:04 AM
Guys,


I have installed fedora 13 , 86_64. and was working fine until now. The problem was that JEXEC service FROZE while booting.So i removed it /etc/init.d (Got help from online forum). The next time when i booted ATD service FROZE , so i removed it by the same way. Next it was the turn of CROND followed by KSM , KSMTUNED. Then came ABRT-DAEMON which i had to type a #yum erase abrt* command. Finally it came to the turn of SM-CLIENT. I dont know where it is or what it is. :( .Didnt find quality posts on the internet. What the heck should i do and i dont want to do a reinstall. I a newbie with little or less knowledge about linux as always.:confused:

JEO
22nd August 2010, 09:26 AM
The jexec service is usually one of the last services you see before the graphical (Xorg server) starts. Perhaps you have a problem with your video driver causing X to freeze. Did you do any updates to that? What video card do you have? You can use lspci to find out. Try booting into runlevel 3 (text mode). Press a key early in the boot sequence to display the grub boot menu, hit e to edit, select the kernel command line, hit e append "linux 3" to the kernel command line, hit enter, then hit b to boot.

jpollard
22nd August 2010, 10:17 AM
Maybe you have a memory issue that only hits after filling memory up to the problem
area?

synops
24th August 2010, 12:00 PM
May thanks for the helpful gesture.:) My video card is ATI Radeon 5450 (basically 5000 series).The problem cropped up while I was doing an update (I don't know which one it was).I have bunch of files to update.
After reaching text mode. I ran a startx command to give an error log like.


X.Org X Server 1.8.2
Release Date ....blah blah blah
..
.
.
.


.


.......

waiting for X server to shutdown
backtrace:
0: /usr/bin/X
1:
2:
..
..
..
10:

Segmentation fault at address 0x10

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting.


Does that do any help ?????:rolleyes:

jpollard
24th August 2010, 12:57 PM
You may have a memory problem - try running memtest for a while to find out.

synops
24th August 2010, 01:01 PM
Dude how 2 do it

jpollard
24th August 2010, 02:27 PM
memtest is on the install CD/DVD. You select it at boot time.

You can have it installed in /boot, but memtest doesn't get used that much.

JEO
24th August 2010, 04:16 PM
You can try looking through your /var/log/yum.log near the end you should see the packages that were updated. Suspect any that start with xorg, mesa, or the kernel. Those are the most likely to be the cause of X crashing. If it's the kernel you can just hit a key early in the boot sequence to bring up the grub boot menu, then hit the down arrow to select the previous kernel then enter to boot.

For the other packages you can try the "yum downgrade <package1> <package2> ..." command.

synops
24th August 2010, 06:38 PM
@ jpollard : memtest takes a hell lot of time.After 4 hours of testing it didnt show an error.Therefore still no good.

@JEO: Its a NEGATIVE. I repeat a negative on xorg , mesa ,kernel.And I think I have only one version of kernel , I dont see any kernel version to change to.

synops
4th September 2010, 04:26 AM
Hey ....one last shot.


Not going 4 memtest. Going for the downgrade option.yum downgrade <package1> <package2> . where will i find the package1 and package2.You know ..how to look it up in log/folder :(

jpollard
4th September 2010, 01:35 PM
Well, If memory and processor are good then the only thing left is a failing disk controller (well, other than the motherboard I/O subsystem).

synops
30th November 2010, 04:27 PM
Crap dude .... I just went in for a reinstall .. Tricks did not work.



Lesson learned for a NEWBIE .... Services do not work Go For reinstall....

jpollard
30th November 2010, 08:57 PM
That depends on WHY the services don't work.

This would work if there are some severe misconfigurations involved
where the reinstallation resets everything back to a minimum.

It won't work at all if it is due to random hardware failures.

murenti
17th April 2011, 12:42 AM
Hi fedora 14 did an automatic update and on reboot it hangs displaying the "f" before the login menu. The "f" is how I now feel......... I do "fn+f2" as it is booting and it displays the sequence of loading items which report all is "ok" until it gets to "jexec services" and then it hangs.
I beleive the "jexec service" is a Sun Java item but I am not sure.
I would appreciate anyones help to solve this issue as I have been using Fedora successfully for a number of months and need to get data from the machine.
Many thanks in advance for you help

JEO
17th April 2011, 01:46 AM
If you look at the service load order you will see that the sun java jexec service is one of the last services to load (before rc.local). The real problem is most likely that you did a kernel or Xorg update and the X server is not starting. Many times this happens if you update the kernel but not the corresponding video driver kernel module (kmod from rpmfusion).

Try hitting a key early in the boot sequence to bring up the grub boot menu, hit the down arrow to select the previous kernel and see if it boots.

marko
17th April 2011, 02:28 AM
Or better, from the grub menu append a 3 to the kernel line so it boots to multi-user, no X mode.
(in the grub menu, highlight the kernel, press (e)dit, append the 3 at the end of the line starting with "kernel",
then enter to save and (b)oot

See if the services all work (that is, this will test if the services are ok ).
Then use switchdesk to setup X:

su - ( become root user)
<root user password>
yum install switchdesk
exit (to exit root user and go back to your normal user account)
switchdesk gnome

startx --> this will start X

murenti
17th April 2011, 04:15 AM
Thanks for your reply, I already tried the other 2 kernel versions but neither worked. I also edited the grub to allow access to a selected services start and it still doesnt. Also when I do a selected services start do I simply type "reboot" for this to happen at next reboot?

---------- Post added at 12:45 PM ---------- Previous post was at 11:34 AM ----------

Hi I have tried reboot with the other 2 kernels with no success and I have tried to selective start services but it is not working either as it seems to stop on other services. I can boot into quiet level 1-4 but not 5. When I have used "chkconfig jexec off" or deselected "jexec" from "ntsysv" and done an exit it does not seem to make any difference. i have been able to login into my login up to quite level 4 but I do not know what to do from there and I would be grateful for any assistance.

JEO
18th April 2011, 03:48 AM
If you can boot into runlevel 3 you can try downgrading the previously updated packages.

A way to do them all at once is with the yum history command.

su -
yum history

You will see a list of transaction numbers, newest at top. Let's say the most recent was 44

yum history info 44

will list those packages.

yum history undo 44 will try to downgrade all of them at once, or you can do a yum downgrade (package names seperated by spaces). Since the X server isn't starting, try to downgrade any Xorg packages that were most recently updated in the last transcation.

murenti
18th April 2011, 04:10 AM
That is excellent information, thanks. I have already reinstalled the machine (unfortunately).
Many thanks for your input.

chaos911
20th June 2012, 02:55 AM
The video driver probably needs to be re-installed. When the kernel is updated the video driver has to be compiled with new kernel and re-installed. This goes for any kernel module that has been manually installed.

What you are seeing is the last service starting and then hanging up when trying to start the X server. That is why it appears to be different services.

I know it is a late reply but I figured if someone came along with similar issue, they would see what causes that symptom.

murenti
20th June 2012, 02:58 AM
Sorry it was to long ago for me to remember, thank you for taking the time to respond.