PDA

View Full Version : F13 won't boot with intel graphics



alicemcline
18th August 2010, 11:03 AM
hi
i previously posted a thread http://forums.fedoraforum.org/showthread.php?p=1391393 that was regarding gaming issue, but now i got a bigger issue..

i installed Intel 2010Q2 graphics package (http://intellinuxgraphics.org/2010Q2.html) from http://intellinuxgraphics.org/2010Q2.html

i first upgraded xorg-x11-server and related packages and installed devel package using yum.. later i compiled and installed kernel 2.6.34 and other packages included on http://intellinuxgraphics.org/2010Q2.html..

i rebooted the system and it showed display driver unknown so, i used system-config-display --reconfig and it detects my mobile 4 intel chipset..
and when i reboot, GUI won't load .. when services finish loading screen goes blank and harddisk light blinks at constant intervals and i can't switch from GUI to CUI either using CTRL + ALT + F2 etc .. :(

plz help .. i have this configuration http://www.smolts.org/client/show_all/pub_e125b0f2-ec63-47d0-b6db-5ab8c6f1729e .. graphics is i915

PS i am able to login into single user and change xorg.conf

schotty
18th August 2010, 11:49 AM
I am not sure if this applies to you or not, but this link solved my nvidia proprietary driver issue:
http://forums.fedoraforum.org/showpost.php?p=1347855&postcount=43

I had the system lock upon loading xorg up. The issue stems from the intel chipset that my Asus laptop has.

HTH

alicemcline
18th August 2010, 01:13 PM
hi schotty
thanks for reply :)
i went through that thread and others linked to it.. but, adding iommu=soft didn't work.. it still shows blank screen..

btw, following is the xorg.conf that is not working..(its not working without Module and DRI sections also..)

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by system-config-display
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105+inet"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "intel"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Module"
Load "glx"
Load "dri"
EndSection

Section "DRI"
Mode 0666
EndSection

alicemcline
19th August 2010, 06:06 PM
setting driver to vesa isn't working either :s

any ideas .. anybody? :(

alicemcline
26th August 2010, 10:34 AM
ok i reverted to kernel 2.6.33.8-149.fc13.i686.PAE .. reinstalled libdrm\* cairo\* etc using yum reinstall

also, reinstalled all xorg-X11-drv\* from InstallMedia and upgraded it using updates.. updated xorg\* kernel and libdrm..
ran fixfiles onboot..

even now, intel drivers showing blank screen.. vesa drivers showing flickering screen now (weird).. and fbdev is working ok..

when i try to boot without xorg.conf i get this 20022 ..

plz help :(

stevea
26th August 2010, 11:13 AM
Your Xorg.0.log seems to be truncated right where it gets interesting. If should be probing the interfaces and performing the EDID queries next.

Is that all you got in the log ?
Is X locked up (maybe you could strace the process).

alicemcline
26th August 2010, 12:39 PM
hello stevea
its complete Xorg.0.log .. X shows blank screen and does not do anything even if i wait for 15 - 30 min.. i press power button and it seems to be shutting down normally (although in blank screen)..

i ran strace .. here is log 20024..

i found following in strace logs that makes me believe libdrm is creating problem..

......
open("/dev/vga_arbiter", O_RDWR) = 8
read(8, "count:1,PCI:0000:00:02.0,decodes"..., 64) = 64
write(8, "target PCI:0000:00:02.0", 23) = 23
read(8, "count:1,PCI:0000:00:02.0,decodes"..., 64) = 64
writev(2, [{"X", 1}, {": ", 2}, {"symbol lookup error", 19}, {": ", 2}, {"/usr/lib/xorg/modules/drivers/in"..., 42}, {": ", 2}, {"undefined symbol: drmCheckModese"..., 46}, {"", 0}, {"", 0}, {"\n", 1}], 10) = 115
exit_group(127) = ?

i reinstalled libdrm\* but, still same error..