PDA

View Full Version : [GDM & nm-applet]



imprez
9th August 2010, 12:49 PM
Hi,

I'm new on this forum, so hello everyone.

I'd like to know if network-manager applet could be run on gdm login menu.


Cause i would like to get connected on my network to reach kerberos serveur to login.

nm-applet on gdm menu would be the best way to do that.

oxala
9th August 2010, 01:49 PM
Hello imprez,

I am 95% sure the answer is yes. The how-to is in the gnome gdm admin guide which can be found at gnome.org if it is not already in the Fedora installation. The non-detailed might-be-wrong how-to from my memory is that you would copy the nm-applet.desktop file to /usr/share/gdm/autostart/LoginWindow.

Another alternative would be to make whatever connection you want to be persistent the "default" configuration in the nm-applet. When you do this, you will be prompted for root password and a system default is created. I'm just not 100% sure that it would be available on reboot as I rarely reboot.

Have fun!

imprez
9th August 2010, 02:19 PM
Hello Oxala.

I've already try to copy the nm-applet.dektop with no succes.

But I don't think this is the only thing to do. Must have put smothing in gdm-freeter-login-window.ui or in gdm gconf

oxala
9th August 2010, 02:43 PM
Hello again,

Good thing I did not forget the "might-be-wrong" part :).

http://library.gnome.org/admin/gdm/stable/configuration.html.en#autostart

Section 5.2


Any .desktop files in this directory will cause the associated program to automatically start with the login GUI greeter

But the previous paragraph:


[The] directory contains files in the format specified by the "FreeDesktop.org Desktop Application Autostart Specification". Standard features in the specification may be used to specify programs that should auto-restart or only be launched if a GConf configuration value is set, etc.

I've just read these two sentences five times and I still don't know what they are actually saying. I can only infer that since the directory only contains files of the ".desktop" variet, there may be a value inside nm-applet.desktop that needs to be modified. It's just an inference .... but the best I can do after reading those two sentences five times .... :D

---------- Post added at 08:43 AM CDT ---------- Previous post was at 08:37 AM CDT ----------

oooooooo .... maybe not a bad inference ....

orca


AutostartCondition=GNOME /desktop/gnome/applications/at/screen_reader_enabled

if could just infer what AutostartCondition=GNOME really means .....

imprez
9th August 2010, 06:14 PM
what i've done :

copied .desktop to /usr/share/gdm/autostart/LoginWindow/

gconftool-2 /desktop/gnome/interface/accessibility to true
gconftool-2 /desktop/gnome/applications/at/nm-applet to true.

Still no result any one have an idea ?

oxala
9th August 2010, 07:38 PM
Just to make sure,

assuming that you have choose correct settings ... you must use "sudo -u gdm gconftool-2 xyxyxyxy/xyxyxy" as the gconf db is a per user db and gdm runs under the uid "gdm".

I have one other idea ... but need to look at gconf db for a few mins ....

As an infamous politician once said, "I'll be back!"

---------- Post added at 01:38 PM CDT ---------- Previous post was at 12:26 PM CDT ----------

Create entries in gconf db as the gdm user for 1 or more of the following:

1) /apps/panel/applets
2) /apps/gdm/simple-greeter/settings-manager-plugins/
3) /apps/panel/default_setup/applets/
4) /desktop/gnome/session/required_components

Note, probably easier to use gconf-editor than gconftoo2. So to try these hacks (and they are hacks ... I have no idea if any of this will work) ... run "sudo -u gdm dbus-launch gconf-editor"

If you get an error about "unable to open display", from a terminal window as the same user that you logged into gnome, type "xhost + si:localuser:gdm" and try again.

And now I am officially absolutely out of ideas ... until my next idea ... :D