View Full Version : [SOLVED] Need Help for 389 Directory Server Installation

7th August 2010, 11:14 AM
Hi All,
I am first time working on 389 Directory server. I have installed 389 Directory Server on RHEL5.5 Server. using following steps
1. yum install java-1.6.0-openjdk
2. yum update
3. rpm -ihv epel-release-5-3.noarch.rpm
4. cd /etc/yum.repos.d/
5. wget www.linuxmail.info.files/fedora-ds.repo
wget www.linuxmail.info/files/fedora-ds.repo
6. yum install 389-ds

389-ds installation completed successfully without any error but when I want to setup it, I didn't find any fedora directory in /opt or any where also tried to find setup-ds-admin-pl script but it is also not available anywhere on server.
Can somebody help me here?

Thanks and Regards,

10th August 2010, 03:19 AM
Hi All,
Its 200+ views already on this thread but still not single update ?? Can somebody pls. throw some light on this issue ?

Thanks and Regards,

10th August 2010, 03:42 AM
Yeah, use Active Directory, it's better documented. :)

Seriously, it's probably not that widely used yet, as it's still somewhat immature. I imagine that no one who has seen the thread yet, had an answer.

As for the missing script, are you sure that you're following a tutorial for the version of it that you're running? (This seems to be common with Sun, they constantly change things, and the documentation doesn't get updated for awhile) Otherwise, it's possible that the script was installed in an unexpected place--I would run updatedb and then run locate, to ensure that the script isn't there.

Do they have their own forums? That might be a better place to ask.

10th August 2010, 07:32 AM
Thanks a lot :)
Is is possible to install AD in linux. Can you pls. provide me good links as I am very new to directory server on RHEL-5.

10th August 2010, 11:40 AM
I'm sorry, it was a joke, hence the smiley at the end of the sentence. AD is Active Directory, MS' version of a directory server, though AD actually does more than that--it is, as mentioned well documented, but only available with a Windows server.

There is also Sun Directory server, again with documentation scattered all over the place, and often a version behind. There's Sun's open directory server, the documentation seems a bit more gathered, but not sure what will happen with it in the future, with Oracle. There's apache's directory server, which I haven't used. There is, of course, openldap, which, used with phpldapadmin will act in a similar way for many aspects of a directory server. For that one, at least, I can give you a page, my own.

11th August 2010, 06:12 AM
Thanks a lot smr54.
Your trick worked here. I updated db and locate file and wow !!! :) found setup file in /usr/sbin/setup-ds.pl

Thanks again for your valuable tips :)

11th August 2010, 08:54 AM
Glad I was able to help, especially since, as I mentioned, I'm not familiar with it. Good luck with it.