PDA

View Full Version : [SOLVED] Yum, tar.gz, or rpm



jj97403
6th August 2010, 08:44 PM
If one uses F13 out of the box and relies and defaults, what is the proper package to choose when downloading software -- YUM, tar.gz, or rpm.

oxala
6th August 2010, 09:44 PM
It's rpm ... but you should not even need to know that much ... after installing fedora, add the fusion package repositories: http://rpmfusion.org/ and it will probably have all you want.

I do not recommend installing rpms downloaded from this site or that site unless you really understand what you are doing ... if you do not ... stick with the standard repos .... lots of great stuff there ...

Generally, tar.gz packages are just source code that you may compile yourself. You will probably never need to go there.


cwight

assen
6th August 2010, 09:51 PM
Hi,

If it is something you'll be using actively, go for yum - it will keep your package always up to date. If you only want a test drive, an RPM will do the job - you can uninstall it later. .tar.gz is source file - if you're not a developer, use as last resort only.

WWell,

Dies
6th August 2010, 10:10 PM
I assume you're talking about Adobe Flash. Go with YUM then install flash-plugin, even up to date versions have a ton of issues so it's definitely not something you want to be running an outdated version of if you can avoid it.

Yum = add the repository to your system so you get updates
RPM = install just the package, one-time thing - no updates
tar.* = manual installation

Oracle4747
6th August 2010, 10:30 PM
The one exception being themes. Those are usually packaged in .tar.gz's which you can simply drag and drop into the Appearances panel and they will self-install.

jj97403
6th August 2010, 10:53 PM
Wow. Thank you for all the great (GREAT!!) input. I always stick to the standard repos, but Adobe was is one of the few I couldn't get from the repos (Opera and Chrome are the only others that I can think of).

I don't know why but I always installed adobe RPM, but for now on I'll do YUM.

Thanks again.

Asgard
8th August 2010, 09:54 AM
I have a related issue. Being new to rpm distros, and new at all in Fedora.

A simple thing I don't know what I'm doing wrong:

[jeff@lappy ~]$ su - jeff yum install flash-plugins
Password:
/usr/bin/yum: line 2: import: command not found
/usr/bin/yum: line 3: try:: command not found
/usr/bin/yum: line 4: import: command not found
/usr/bin/yum: line 5: except: command not found
/usr/bin/yum: yum: line 23: syntax error near unexpected token `('
/usr/bin/yum: yum: line 23: `""" % (sys.exc_value, sys.version)'


hmmm...
hepl? :)

jj97403
8th August 2010, 10:26 AM
I'm literally a novice, and apologies if I'm way out in left field, but two things come to mind:

1) Are you running the commands as root or user? Looks to me like your running as user and you need to run them as root.

2) If above is not the problem, then the other thing is 'yum install flash plug-ins' only work after you've downloaded the yum software from Adobe website. You can't just install the flash-plugins without first downloading it from Adobe.

I used to install rpm from Adobe website, because I could never figure out how to get yum going, but after I posted this thread I learned that you choose yum version from Adobe website to download, and then go into terminal as root and run 'yum install flash-plugins.'

assen
8th August 2010, 11:04 AM
Hi,



[jeff@lappy ~]$ su - jeff yum install flash-plugins


You're not using "su" properly; in addition, package name is "flash-plugin", not "flash-plugins". "man su" should get you a description of options and usage examples. In your particular case this should be enough:



su -c "yum install flash-plugin"


WWell,

BaldEagle
8th August 2010, 07:27 PM
jj.....
If you want opera download it from here:
http://www.opera.com/browser/download/
Just select Fedora - Download - and click the package.

For Chrome you need to add the Google repo.
Open a terminal and paste the following:

su (followed by your password)

then paste the following in one go

cat <<EOF > /etc/yum.repos.d/google.repo
[google]
name=Google - i386
baseurl=http://dl.google.com/linux/rpm/stable/i386
enabled=1
gpgkey=https://dl-ssl.google.com/linux/linux_signing_key.pub
EOF

Now search for chrome in your package manager, it should be there.

jj97403
8th August 2010, 08:10 PM
Assen...
What is the difference between "su -c" and "su -"

I've always done "su -" then password to get to root@localhost, and then I can run the command, but it looks to me if you use "su -c" it allows you to bypass the step of logging in as root first. You still need to input root password, but it allows me to skip the initial step of getting to root first. It just saves one step, or rather combines two steps in one line. Is that correct?

Bald Eagle.....
Awesome thank you!!!
jj

oxala
8th August 2010, 09:55 PM
Hello novice friends,

IMHO, the BEST command to know on linux/unix, "man". At a terminal prompt, type "man su" and the author of the "manpage" will explain the difference options to you much better than I can.

Type "man chmod" and you will read all you ever did not want to know about the chmod command.

Type "man man" ... and you can read about the "man" command ....

If you are coming from M$ land ... it must be shocking to have relevant documentation so easily accessible ... but you'll get accustomed to it ..... :D

recondite
23rd August 2010, 05:24 AM
Hey dudes, I just got Linux installed and downloaded and installed flash at least three times (first from the Adobe site with the GUI, then with rpm, then with yum using $ su -c "yum install flash-plugin" as shown by someone above. I kept trying because after each install I went to youtube and I still could not run flash. It kept tellling me I had to update my version of flash. It was my first time installing to Linux so I thought I was doing something wrong in the install. Now I suspect some other problem. The installs seemed to go OK, except I got "already installed" warnings. I relaunched Firefox and even rebooted my computer a few times and still can't run the Flash player. What am I doing wrong?

---------- Post added at 08:24 PM CDT ---------- Previous post was at 08:22 PM CDT ----------

Hey man, maybe somebody should mark this thread "unsolved"? ;) On the other hand,I guess I'm digressing ...

Trunkton
23rd August 2010, 05:59 AM
Yum allows for easy updates, compiling a .tar.gz is no where as easy to update, when updates are available manual intervention (re-compiling and updating) is required.

jj97403
23rd August 2010, 07:25 AM
try the following:

1) go to Adobe website http://get.adobe.com/flashplayer/?promoid=BUIGP and download "YUM for Linux"
2) then from your terminal input the following code:

su -c "yum install flash-plugin"

3) authenticate password when prompted and choose yes to install. finished.

Hope this works for you.

recondite
24th August 2010, 12:22 AM
jj97403, I did that already.

jj97403
24th August 2010, 04:22 AM
Odd.

In terminal, after you enter the code, I wonder whether you at least being asked "y/N" in regards to installing flash-plugin? If you are not getting that far, something is amiss.

If you are, (and still in terminal), and you say "y" and you watch it install (still in terminal), it will give you a message that "Complete!" (still in terminal). You don't want to close the terminal before the installation finishes.

Another question I have is, when you installed F13, did you install all the automatic updates, and did you say "yes" to everything? It all would have been automatic, but you still needed to grant authentication in order to update, and it would have taken time for all the updates to install.

If you did, I wouldn't know why the above instructions failed. I would venture a guess that you are doing something wrong in the terminal.

Make sure you've download "YUM for Linux" from Adobe and try establishing root access first, instead of doing it all in one line.

1. Open the terminal and enter the following. "su -" (Not the quotation marks, just su -)

2. (Then it will ask you for password), and enter password

3. Then enter "yum install flash-plugin" (again no quotation marks).

4. Wait for it to load and install and press "Y," when prompted y/N for install.

4. You should get a message "Complete!"

If it still doesn't work, and you don't need to save any data, I'd start from scratch and reinstall distro. In my experience, sometimes it is just easier to start over.

recondite
24th August 2010, 05:53 AM
I tried that already.

---------- Post added at 08:52 PM CDT ---------- Previous post was at 08:37 PM CDT ----------

Sorry, last comment was a mistake (I posted that already but didn't see it get posted, so I reposted).

I found another thread which discusses issues (bugs?) with Adobe Flash and 64-bit fedora. That might be helpful. I might review that again later. I'm also trying another browser (Opera) but no luck so far. The wikipedia article on Adobe Flash has some info too. But for now, I have to call it a day... I think maybe I need the 64-bit version of Flash and the downloaded from their site gives the 32-bit version.

Thanks for the help! I did get the y/N at some point and the "Complete!" message. I don't recall the F13 install details but I would have likely said "yes" to everything, I installed about 1200 packages from the DVD, I did not use the Live CD.

In Opera I see "Shockwave Flash" in the plugins list. Not sure how to find it in Firefox though.

---------- Post added at 08:53 PM CDT ---------- Previous post was at 08:52 PM CDT ----------

Might be a browser configuration issue.

jj97403
24th August 2010, 09:28 AM
If you got the msg "complete!" IMHO flash-plugin should have installed and working, but I'm new at this.

With regards to the "yes," it would have been the very first "yes" after Fedora 13 install, and saying yes is practically automatic, so I'm sure you did it.

Maybe this is what is interfering with your flash -- about 3 weeks ago, there was a bug that was preventing software updates. The message is still at the top of the page in small letters at http://FedoraProject.org/ , or here at, http://lists.fedoraproject.org/pipermail/announce/2010-July/002843.html .

You could try downloading a new live CD and reinstalling.

And there is always Chrome, which already has flash integrated into it.

Good Luck.

P.S. I just saw that Leigh's F13, F12 & F11 Nvidia driver guides in Guides & Solutions Forum, now recommends updating kernal before installing video drivers. It might have something to do with the bug that was preventing software updates, and it wouldn't hurt for you to try. Who knows, it might solve your flash problem:



Code:

su
yum update kernel*
reboot



After kernal update, I suppose, you might need to try and reinstall flash-plugin as discussed above.

recondite
24th August 2010, 04:33 PM
I just downloaded and installed google chrome and i have the same problem -- Adobe Flash does not seem to be recognized by the browser.

---------- Post added at 07:33 AM CDT ---------- Previous post was at 07:22 AM CDT ----------

Adobe says use 32-bit browser in most 64-bit operating systems to run flash.

http://kb2.adobe.com/cps/000/6b3af6c9.html