PDA

View Full Version : [SOLVED] Steam not running



seanroth
1st August 2010, 01:17 AM
I followed this guide: http://fedorasolved.org/gaming-solutions/installing-steam-using-wine
but still am having issues with steam; it won't run at all.
I have an nvidia card with the drivers properly installed (per http://forums.fedoraforum.org/showthread.php?t=204752) and my arch is x86_64.

Here's the output:



[wot@startop Steam]$ wine Steam.exe
CellID: Fetching server list from CSDS. . .
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
err:ntlm:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path.
err:ntlm:SECUR32_initNTLMSP Usually, you can find it in the winbind package of your distribution.
CellID: CSDS returned 165 servers.
CellID: Connecting to 203.77.185.185:27031. . .
fixme:urlmon:CoInternetSetFeatureEnabled 5, 0x00000002, 1, stub
fixme:urlmon:CoInternetSetFeatureEnabled 10, 0x00000002, 1, stub
fixme:dwmapi:DwmSetWindowAttribute (0x1009a, 2, 0x32d344, 4) stub
fixme:dwmapi:DwmSetWindowAttribute (0x1009a, 3, 0x32d340, 4) stub
fixme:dwmapi:DwmSetWindowAttribute (0x1009a, 4, 0x32d33c, 4) stub
CellID: Connect to 203.77.185.185:27031 took 158 MS
CellID: Nothing beat our old best time of 32 MS


Any help would be greatly appreciated :)

---------- Post added at 05:17 PM CDT ---------- Previous post was at 01:26 PM CDT ----------

Found the solution! Here's what I did, in case anyone else has issues with this in the future:
For some reason gecko wasn't being installed correctly by wine or winetricks, so I had to do it manually. To do that, follow the instructions here:
http://wiki.winehq.com/Gecko
THEN, do the following:


wget http://www.kegel.com/wine/winetricks
sh winetricks corefonts allfonts tahoma gecko gecko-dbg vcrun2005

If that still doesn't work, try a

sh winetricks steam