PDA

View Full Version : Package Update Notifications Fixed - Jared Smith



bob
30th July 2010, 09:51 PM
Recent updates to Fedora introduced two unexpected bugs, either of
which results in users no longer seeing notifications of or being able
to apply new updates.

Updates to the relevant packages have been shipped to fix these
issues, but users will not receive notifications for them unless they
first apply the pending fixed updates using the "yum" tool. (Please
note that these issues should only affect Fedora 13. Fedora 12 does
not appear to be affected.) Packages fixing these issues were pushed
to the Fedora software repositories around July 22, 2010. Users who
have done a manual "yum update" since that push may have already
received these fixes.

To fix the issue, please:

1. Open a Terminal (Applications > System Tools > Terminal)

2. Type either of the following commands and enter the password for
the root user when prompted.
a. To choose to apply all pending updates now:
su -c "yum -y --skip-broken update"
b. To choose to apply updates fixing only the specific issues mentioned above:
su -c "yum -y --skip-broken update gnome-packagekit selinux-policy"

3. Log out and and then log back in, or reboot your computer. Note
that logout/login will complete the fix for the notification issue.
However, if you applied all updates in the previous step, you may need
to reboot for other updates that require it.

We apologize for the inconvenience, and we are working on further
improvements to our testing and quality assurance processes to avoid
this and similar problems in the future.

If you have any further questions or require additional assistance,
please refer to
https://fedoraproject.org/wiki/Communicating_and_getting_help (https://fedoraproject.org/wiki/Communicating_and_getting_help) for ways
to get additional help from the Fedora community.

--
Jared Smith
Fedora Project Leader

robert-e
31st July 2010, 01:05 AM
Hi,
For what it's worth: under F12, I ran Yumex, to check for updates; none were offered. I closed Yumex, and then from the terminal I became root and ran:
yum -y --skip-broken update
Aprox. 5 or 6 updates were downloaded and installed, most seemingly related to Keyboard.

You may want to check your F12 system.

Regards,
Bob

hephasteus
1st August 2010, 09:13 PM
This appears to be related to ..
selinux-policy-3.7.19-41.fc13
selinux-policy-targeted-3.7.19-41.fc13

I updated everything on my other test box except these 2 packages and adding and removing and updating works fine. But if you update to these then selinux goes on a rampage and breaks python so severely that there appears to be no way out of it.
If I could find a way to get selinux to relabel on next reboot I think I can downgrade to the selinux-polic-3.7.19-39.fc13 and selinux-policy-targeted-3.7.19-39.fc13 that doesn't break everything.

sidebrnz
2nd August 2010, 03:16 AM
I've been away since July 27 and just saw this message. I tried option b. on my F 13 box and was told No Packages marked for update. Will try option a.

Update: same results.

AlFrugal
6th August 2010, 12:59 AM
I've been away since July 27 and just saw this message. I tried option b. on my F 13 box and was told No Packages marked for update. Will try option a.

Update: same results.

I only became aware of the notice when I read Fedora Weekly News 137 on August 5. I too tried both options and got the same result: No Packages marked for update.

I know my selinux-policy is still broken because logwatch is getting an selinux permission denied when it tries to run sendmail to email the daily logwatch report report to me. (I'm running F13).

sidebrnz
6th August 2010, 03:02 AM
Right now, I'm at a convention on the East Coast; my desktop's in California. I've had at least one update work since I last posted, and one that wanted to update kmod-nvidia to a version that doesn't match any kernel I have. I've also had an update (I use yumex for it on both machines.) work fine on my laptop.