PDA

View Full Version : [SOLVED] Flash-plugin not working in Google Chrome



Lo Zeno
1st July 2010, 11:17 PM
After upgrading to the latest version of Google Chrome, despite the announcement that it now has a flash plugin integrated, I can no longer see any flash video or flash site with Chrome. I always see the "missing plugin" message, despite having Flash installed (I installed it using Autoten).

I run Fedora 13 64 bit, can anyone help?

EDIT: just to clarify, Flash works just fine in Firefox instead.

mtk
2nd July 2010, 12:58 AM
the flash plugin is only built into the 32-bit version of chrome. like you, i'm an FC13
x86_64 chrome user and we're left high-and-dry by adobe's abject failure. i really miss the pandora reggaeton channel (sniff).

Lo Zeno
2nd July 2010, 06:46 AM
Ouch!
That sucks... I guess there's no way to make Chrome use the same flash plugin I use in firefox?

CtrlK
2nd July 2010, 08:19 AM
Have you used the wrapped 32bit method? I am running 64bit as well and flash player works swell for me in Chrome. http://www.mjmwired.net/resources/mjm-fedora-f13.html#flash

Also, have you tried this? http://forums.fedoraforum.org/showthread.php?t=205642&highlight=flash+player+64bit

I've forgotten what I did to make it work and to be honest I don't know how to check what I've done. However, I do know that if there's a will there's a way. Hours and hours of Google searches and FF searches later my machine is working like a beast. ;)

mtk
2nd July 2010, 03:05 PM
the 2nd link you posted (from the praiseworthy and omnipresent leigh) refers, i think, to the now risky 64-bit beta linux flash plugin. that's the one that was just yanked after a recent adobe flash vulnerability announcement. and there is no replacement (yet).

CtrlK
2nd July 2010, 08:24 PM
OK, so how about wrapping the plugin? I believe that's what I'm running and I am having no issues.

Falven
4th July 2010, 10:01 PM
Ouch!
That sucks... I guess there's no way to make Chrome use the same flash plugin I use in firefox?

1. Open up chrome command properties (richt click, properties)
2. Type in --enable-internal-flash at the end of command
3. You should now have flash

cheers!

Helios38
5th July 2010, 05:21 AM
Don't wrap the plugin.

Download the 64bit Flash plugin here (http://go2.wordpress.com/?id=725X1342&site=nxadm.wordpress.com&url=http%3A%2F%2Fhome.scarlet.be%2Fvar%2Ftmp%2Flib flashplayer-latest_closed_beta.linux-x86_64.so.tar.gz&sref=http%3A%2F%2Fnxadm.wordpress.com%2F2009%2F04% 2F26%2Finstall-64-bit-adobe-flash-player-on-ubuntu-904%2F)

extract it using

tar -xf <file>

move the .so file with root privileges to

/usr/lib64/google-chrome/plugins/

Sometimes that directory doesn't exist for some weird reason.

Poke around until you find it.

Lo Zeno
5th July 2010, 06:36 PM
I have tried all the solutions you suggested, except the last one: the 64bit plugin, I suspect, is the alpha unstable one, and I've been told that it's support has long been discontinued and has several security holes, so I am not really willing to use that.

Anyway, none of the solutions seemed to solve the problem, Chrome still shows the "You need the latest Flash player to see this video, Click here to get Adobe Flash player" message. :\

I'll use Chrome without flash, and open up Firefox when I need it.

---------- Post added at 07:36 PM CDT ---------- Previous post was at 07:13 PM CDT ----------

An addendum: it seems that after installing Chrome, the flash plugin was working fine, only a little slow, and the other person which has access to this PC had uninstalled Chrome and reinstalled it, and it was after reinstalling it that the Flash plugin stopped working. I've been told this only now (and from now on I'll be the only one to know the root password of this PC, that's sure :P )

Falven
5th July 2010, 10:30 PM
My solution should have worked (http://www.downloadsquad.com/2010/03/30/internal-flash-plugin-integration-hits-google-chrome-dev-channel/), and I know the 64 bit flash plugin works, because I am using it...

Lo Zeno
5th July 2010, 11:06 PM
All the solutions apparently should have worked...
No offense, but this (see attachment) is what I see, despite the --enable-flash-flash parameter (which you can see I added as you said to the launcher properties).

And I don't argue that the 64bit flash plugin works, as I said that's the only option that I did not try; and since it's old, and apparently has security issues, I don't feel like using it. Security is rather important for that PC.

Lo Zeno
8th July 2010, 10:23 PM
I managed to make it work!
I simply started Chrome with the --enable-plugins param, and Flash was there working.

I guess that one of the above solutions which I tried actually DID make Flash available to Chrome again, and the --enable-plugins was what I needed to force Chrome to re-scan its plugins folder and see that Flash was there.

HombreBlunt
24th July 2010, 10:23 PM
Hey folks, I recently setup flash for FC13 86_x64 systems, HP dv and Dell Inpirion, recent releases. The 32-bit wrapped version did not work for chrome and in firefox it had no sound. I ended up using a saved copy of the discontinued 64bit flash 10 version. Worked great for both browsers. Posted my procedure here:

http://forums.fedoraforum.org/showthread.php?t=248918

-jerry

tokyojoe
3rd January 2011, 03:51 AM
I am using F13 x86_64, I have the following packages installed:
google-chrome-stable-8.0.552.224-68599.x86_64
flash-plugin-10.0.45.2-1.x86_64
firefox-3.6.12-1.fc13.x86_64

with firefox I can watch flash video on youtube without any problem (image+sound)
but with google-chrome I get the image but not the sound.

I grepped the processes and I think chrome is using the same plugin as firefox:
--plugin-path=/usr/lib64/flash-plugin/libflashplayer.so
so why is that the sound does not work with chrome ?

tokyojoe
7th January 2011, 10:32 PM
just to let you know I installed the 32 bit wrapped version instead of the 64 bit one and everything is working now.

DonChino
9th April 2012, 07:48 PM
The following worked for me. I am using Windows 7 64-bit and I could not get Chrome to work with Pandora, since it kept saying "Install the latest version of Flash" blah blah blah. I checked and I was running the latest version of Chrome, so it seems something turned off Flash within Chrome?

Anyway, I right clicked the shortcut in my Quick Launch toolbar and added "--enable-internal-flash" after the last quote. Closed all my Chrome windows and launched Pandora.com.

Now I am listening to my jams while I work. SCHWEET!!!

:dance:


1. Open up chrome command properties (richt click, properties)
2. Type in --enable-internal-flash at the end of command
3. You should now have flash

cheers!

secipolla
9th April 2012, 10:21 PM
You can enable/disable both the internal Flash as Adobe's plugin in chrome://plugins

VernDog
12th April 2012, 11:53 PM
1. Open up chrome command properties (richt click, properties)
2. Type in --enable-internal-flash at the end of command
3. You should now have flash

cheers!

I'll have to try this one. I've been using my own script:

sudo install -m 644 libflashplayer.so /usr/lib/mozilla/plugins/

I try puttting it into chrome plugins but that didn't work.