PDA

View Full Version : system-config-display just ruined my display



xucaen
29th June 2010, 12:55 AM
I did not have any /etc/X11/xorg.conf, so I read on these forums that system-config-display would create one for me. I ran system-config-display and it created an xorg.conf. But now my display is all messed up!! So, I deleted the xorg.conf and nothing changed. Why on earth would the display still be messed up if I deleted the file that was causing it?? Does system-config-display change somethign else??

dd_wizard
29th June 2010, 01:00 AM
Did you restart the X server? Try logging off and back on.

dd_wizard

xucaen
29th June 2010, 01:31 AM
Did you restart the X server? Try logging off and back on.

dd_wizard

Yes, restarted several times. I really thought deleting the xorg.conf file would put everything back the way it was ebcause everything was find before without it. Are there other files that are changed by system-config-display? It is very odd that it would behave this way.

dd_wizard
29th June 2010, 01:41 AM
Try "man 5 xorg.conf" to see a list of all the files xorg uses at start up. Hopefully that'll get you to the culprit.

dd_wizard

Zanpactou
29th June 2010, 02:57 AM
Yeah, oops. Adam warned me about this the other day. Use kde or gnome's native display resolution changer because many new drivers like nouveau don't support the configuration that system-config-display creates.
I think you've more or less worked that out by now though. :(

Thanks,
Zanpactou

xucaen
1st July 2010, 12:55 AM
so, after running system-config-display, how do I restore the system default and remove the xorg.conf so that fedora configures the system dynamically at startup? Simply deleting the xorg.conf doesn't do it.

Thanks,

Zanpactou
1st July 2010, 01:19 AM
It should do. Do you have the nvidia driver installed?

Thanks,
Zanpactou

xucaen
1st July 2010, 01:23 AM
everything is installed and was working perfectly before I ran system-config-display.

Zanpactou
1st July 2010, 02:14 AM
everything is installed and was working perfectly before I ran system-config-display.

Is that a yes? You have installed the nvidia driver by hand before you ran system-config-display?

Thanks,
Zanpactou

xucaen
1st July 2010, 04:10 AM
I did a fresh clean install of Fedora 13 and it auto detected everything as it should. Fedora 13 does that, it auto detect everything and doesn't need an xorg.conf at all! Well, that silly little program, system-config-display, went and did something and it created an xorg.conf. Not sure why it did that, but anyways, I want to delete it seeing as how Fedora 13 doesn't need it and seeing as how it ruined my display anyways so I don't see as much that I need it. So I went and deleted it. But the display was still broke. I don't quite understand it myself. If the only thing that system-config-display did was make a xorg.conf then deleting the xorg.conf should return everything back to cripsy new Fedora 13 defaults. Well, it don't. I'd appreciate it if you know why and you could tell me how to fix it. If not, well I appreciate you try to help and all but maybe we should go and let someone else give it a try. Thanks!

nsnbm
1st July 2010, 05:08 AM
Hello xucaen,

I had success with creating an xorg.conf with the command: Xorg -configure
Xorg has a manpage. The command has to be done as root and without X running at all on the computer ... that is, say, in runlevel 3. It puts the xorg.conf in root's home directory and lets you know how you can test it from there. Or you can install it as /etc/X11/xorg.conf and try it. My understanding is that if you remove the /etc/X11/xorg.conf then the built in X processes will run X automatically and return to the original set up which was created on first installation of Fedora 13. This is what happened in my case anyway. I found the program system-config-display worked better in earlier Fedoras. Ben.

Zanpactou
1st July 2010, 05:29 AM
I did a fresh clean install of Fedora 13 and it auto detected everything as it should. Fedora 13 does that, it auto detect everything and doesn't need an xorg.conf at all! Well, that silly little program, system-config-display, went and did something and it created an xorg.conf. Not sure why it did that, but anyways, I want to delete it seeing as how Fedora 13 doesn't need it and seeing as how it ruined my display anyways so I don't see as much that I need it. So I went and deleted it. But the display was still broke. I don't quite understand it myself. If the only thing that system-config-display did was make a xorg.conf then deleting the xorg.conf should return everything back to cripsy new Fedora 13 defaults. Well, it don't. I'd appreciate it if you know why and you could tell me how to fix it. If not, well I appreciate you try to help and all but maybe we should go and let someone else give it a try. Thanks!
While I appreciate that you are frustrated, that's a lot of words if you still mean no.

I'll just leave you to be rude to everyone else then...

Thanks for nothing would be an understatement,
Zanpactou

xucaen
1st July 2010, 05:57 PM
Hello xucaen,

I had success with creating an xorg.conf with the command: Xorg -configure
Xorg has a manpage. The command has to be done as root and without X running at all on the computer ... that is, say, in runlevel 3. It puts the xorg.conf in root's home directory and lets you know how you can test it from there. Or you can install it as /etc/X11/xorg.conf and try it. My understanding is that if you remove the /etc/X11/xorg.conf then the built in X processes will run X automatically and return to the original set up which was created on first installation of Fedora 13. This is what happened in my case anyway. I found the program system-config-display worked better in earlier Fedoras. Ben.

But why do I need xorg.conf? I read that Fedora 13 doesn't use it because it auto-detects all hardware every time it boots. is that not true? When I delete the xorg.conf, my original settings are not restored.

SiliconSlick
1st July 2010, 08:07 PM
Indeed that is odd... normally nuking xorg.conf should put it back to default (which worked).

You can check for errors/warnings with grep -e EE -e WW /var/log/Xorg.0.log. Either that, or a more detailed read of that log might shed some light on the problem.

SS

nsnbm
2nd July 2010, 02:52 AM
Hello xucaen,

You asked why you would need xorg.conf? If your machine did reset the X configuration to the original specification which it is supposed to detect automatically, then you would not need an xorg.conf. I understood from your experience that your machine did not reset itself to the original X automatic detection and therefore did not give you back the original X environment. I don't know why that would be the case because,as SiliconSlick and Zanpactou mention, it should, and your experience is unusual. I have not had that behaviour from my installation of Fedora 13. So, in an unusual situation where the X automatic detection fails, to try and control the matter, an xorg.conf file would be helpful because it would allow you to tell the X server what you want it to do for you, e.g. what resolution to use. I could conjecture that there is some hardware issue or driver issue, but without more information this is just speculation. Others would know more about that than me. Ben.

xucaen
22nd July 2010, 03:54 AM
Indeed that is odd... normally nuking xorg.conf should put it back to default (which worked).

You can check for errors/warnings with grep -e EE -e WW /var/log/Xorg.0.log. Either that, or a more detailed read of that log might shed some light on the problem.

SS


(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 32.937] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 32.937] (WW) Disabling Keyboard0
[ 32.988] (II) Loading extension MIT-SCREEN-SAVER
[ 33.630] (EE) MGA(0): [drm] Failed to initialize DMA! (-22)
[ 33.630] (WW) MGA(0): Direct rendering disabled
[ 34.397] (EE) No input driver/identifier specified (ignoring)
[ 34.443] (EE) No input driver/identifier specified (ignoring)

---------- Post added at 06:54 PM CDT ---------- Previous post was at 06:51 PM CDT ----------

I am really very shocked and disappointed that the people who make fedora can not understand how it works. It seems like a simple thing really: reset fedora to installation defaults. Do I have to reinstall Fedora to do that? Hardly seems like a viable solutioon since I did absolutely nothing to change my envoronment excpet run that silly command. Why that command doesn't have an undo option is beyond me.

SiliconSlick
22nd July 2010, 04:18 AM
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 33.630] (EE) MGA(0): [drm] Failed to initialize DMA! (-22)
.

I would worry about that line... wow... Matrox... don't see those often.



[/COLOR]I am really very shocked and disappointed that the people who make fedora can not understand how it works. It seems like a simple thing really: reset fedora to installation defaults. Do I have to reinstall Fedora to do that? Hardly seems like a viable solutioon since I did absolutely nothing to change my envoronment excpet run that silly command. Why that command doesn't have an undo option is beyond me.

Fedora is developed and supported by volunteers... all with limited time and often working on other things so not necessarily here. You are welcome to help make it better. Please feel free to file a bug report similar to this one:

https://bugzilla.redhat.com/show_bug.cgi?id=127731

and feel free to share any knowledge you gain.

You may be frustrated but you really have no reason to be "shocked and disappointed"... I'm sure you can get your money back if you don't like it.

SS