PDA

View Full Version : [SOLVED] Problemo



Shaggakhanz
28th June 2010, 04:40 AM
Ok well this has been going on for three days and I finally have time to work on it. A few days ago I installed wine and then ran the updates on Fedora 13 through the gui and it ended in success. I rebooted as prompted went to bed and in the morning I go to use the pc all I see is a black screen with a blinking cursor. I rebooted and went to the optional checklist screen it would go to "Registering binary handler for Windows applications: [OK]. Then the blinking occurs. Press CTRL+ALT+F2 and attempt to do yum updates because I received help yesterday and it was no good. I got about three errors. Today I just tried to uninstall wine but unsure how to do so via commands. If anyone could assist me in which ever way would be more efficient to get this thing running that would be awesome! :confused: Linux Issue is the yum update errors and Linux issue 2 is the Binary handler

forkbomb
28th June 2010, 06:25 AM
I've seen some threads on the libedataserver hangup but I don't know if there's been a consensus on fixing it.

The "registering binary handler" part is likely a coincidence. The WINE server probably just happens to be the last thing loaded before X, and it reads [ OK ]. I'm guessing the machine is hanging hard upon attempting to start X. So removing WINE would probably mean you'd start seeing a hang after "starting atd" instead.

kurtdriver
28th June 2010, 06:34 AM
Hi, issue 1 tells us that you have dependency problems. It also gives the solution. Type


yum update --skip-broken

This will have yum update everything except the packages that have unmet dependencies.

The wine thing has completed, that's why it says OK

Your hostname is l33t?

Shaggakhanz
28th June 2010, 08:48 AM
How do you remove something with command prompt? I will attempt that yum update --skip-broken. I wanted to name it something that was quick to write down.

---------- Post added at 02:48 AM CDT ---------- Previous post was at 02:41 AM CDT ----------

So upon doing that yum update --skip-broken it got to the Finished Dependency Resolution and says Packages skipped because of dependency problems: evolution-2.30.2-1.fc13.i686 from updates
evolution-data-server-2.30.2-2.fc13.i686 from updates

Evil-I
28th June 2010, 03:54 PM
Hi There,

I've had the same issue, not with wine but the same missing dependency. Seems to be that some packages seem to want the older version of libedataserver. This is an error in the package dependencies that hopefully will be fixed over the next day or two.

It's annoying, as I have semi-broken my server whilst trying to fix this before I realised there was a problem with the dependencies. I tried removing the entirety of Gnome and re-installing it via yum trying to fix the issue and have ended up with only half a gnome desktop as several of the key components won't install because of this error. I'm now just leaving well alone as my servers doing most of what I need it too still, I just keep trying yum install "Gnome Desktop Environment" a couple of times a day to see if the issue has been resolved.

the "--skip broken" switch should mean that most things will still update, if not, I think wait until they have fixed it is the only option.

Best,

E-I

AdamW
28th June 2010, 09:25 PM
the yum issue is a mistake on the packager's part, and will be fixed with further updates. it's not related to the other issue. I think forkbomb has likely nailed that. try booting with the kernel parameter '3' (press keys during boot to get to the bootloader screen and edit the boot command); that should boot to a console and not try to start X. if that works, then the problem is in starting X. we'd need to know what packages were part of the update to figure out what broke...

Shaggakhanz
29th June 2010, 07:05 AM
I'm not sure what kernel parameter 3 is. Os that where i can login as either root or my user account? like shown in the picture or is it something else?
-------------------------------------------------------------------

I just attempted to try and perform the command startx and it had a lot of data go through and found this interesting line.....
The PCI device has a kernel module claiming it.
This driver cannot operate until it has been unloaded.
(EE) No devices detected.

Fatal server error:
no screens found

go to blah for support

giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.

AdamW
29th June 2010, 10:12 PM
oh, never mind the '3' thing, I see on re-reading now that your console is working at the 'broken' boot anyway. It looks like you have a broken install of the proprietary driver, or something. Can you post the output of:

lsmod
grep Driver /etc/X11/xorg.conf

? thanks!

Shaggakhanz
29th June 2010, 10:59 PM
i see a lot of stuff with lsmod, i do see the line video 17109 1 nouveau
output 1541 1 video

and with grep Driver /etc/X11/xorg.conf
Driver "kbd"
Driver "nv"

AdamW
30th June 2010, 07:07 PM
ooch. yeah, 'nv' won't work with the 'noveau' module loaded. I'd guess you ran system-config-display at some point for some reason and it set that xorg.conf .

Either delete /etc/X11/xorg.conf (you don't actually need it usually) or change that Driver "nv" line to Driver "nouveau" , and it should improve matters.

Zanpactou
30th June 2010, 08:35 PM
ooch. yeah, 'nv' won't work with the 'noveau' module loaded. I'd guess you ran system-config-display at some point for some reason and it set that xorg.conf .

Either delete /etc/X11/xorg.conf (you don't actually need it usually) or change that Driver "nv" line to Driver "nouveau" , and it should improve matters.

So What Adam is saying is get to the login prompt that you have been using to provide the screen shots, login as root, then use :


rm -f /etc/X11/xorg.conf && reboot

Your machine should reboot and your desktop will load, according to the theory.

You don't need to :

su -
yum erase *wine*
exit

Because it's certainly not a wine problem.

@Adam - It's impressive how you caught that one. ;)

Thanks,
Zanpactou

Shaggakhanz
1st July 2010, 04:22 AM
Why thank you very much!! That fixed it, i got my pc back. Thanks guys

AdamW
6th July 2010, 11:49 PM
no problem, glad we found the issue :)

christianvl
11th July 2010, 07:28 PM
I have the same problem. The


rm -f /etc/X11/xorg.conf && reboot

did not work for me

The result of lsmod command is

Driver "nvidia"

Btw, i was running an update and the computer was turned off during it (canceling the update during it).

Any ideas?

-----------------------------

EDIT

Problem solved. It was a problem with the Nvidia driver. I did


yum update kmod-nvidia

reboot

Then i could login and ran


yum-complete-transaction

to complete the update i've mentioned. Don't know if the problem I had is related with a updade of the nvidia driver or the halt during the update process. Anyway... everything is back to normal now.