PDA

View Full Version : system-config-firewall error



Evil-I
9th June 2010, 05:24 PM
Hi All,

New installation of F13, system-config-firewall was working fine.

Whilst doing other things something seems to have killed it. Now when I launch system-config-firewall after the opening message i get:

"org.fedoraproject.slip.dbus.service.PolKit.NotAuth orizedException.org.fedoraproject.config.firewall. auth: " and I can either redo or quit, redo does nothing quit exits.

Any suggestions?

Thanks,

E-I

CSchwangler
10th June 2010, 07:12 AM
Did you install any updates? I've checked and it runs normal on my system (F13 32 bit).

Evil-I
10th June 2010, 10:37 AM
Did you install any updates? I've checked and it runs normal on my system (F13 32 bit).

Hi There,

Apart from normal yum update and also running the easylife project installer to do some extra stuff I don't think anything out of the ordinary has gone on.

I got fed up last night as I just couldn't seem to get it to work right so I did a fresh install again. All worked great, firewall gui worked etc. Did all updates and installed some extras using easylife and all seemed fine.

This morning though, I've logged in remotely from work and the error is back again. I'm guessing there must be a bug, but I haven't found any references to anyone else having the issue?

This particular machine is my home server and runs F13 32 bit.

Getting a bit frustrated by this now, as it almost seems as if its not just a case of the gui not working, I'm not sure the additional ports I'd opened via system-config-firewall are now open either. My torrent software seems to think the ports that I'd opened for torrenting are blocked.

Any help much appreciated!


---------- Post added at 10:37 AM CDT ---------- Previous post was at 10:22 AM CDT ----------

Hi There,

Also, the text based interface (system-config-firewall-tui) works fine. Just run through that and the opened ports etc seem to be there and are working fine now.

Best,

E-I

kdepfyffer
11th June 2010, 04:57 AM
Does this happen locally and remotely? Im thinking I have seen this somewhere it may have something to do with selinux or policy kit? leaning toward polkit look at your first post.
sry trying to boot up my fedora box atm which is hooked up to the TV and wife is busy watching it lol..
ok if I open a terminal up and su then try system-config-firewall it works fine but as a normal user I get the same error you are getting.

Evil-I
5th May 2011, 01:43 PM
Hi there,

It was exactly that, a user issue. For some reason it was no longer happy running as the standard user (previously it would just prompt for root password). However if i launched it from console as root it works fine. I'm wondering if this is because I'm VNC'ing to the machine?

Sorry for the resurection of a very aged post by the way, but just had the same issue again and on googling was very suprised to find my own previous post!

Many thanks for your help.

E-I