PDA

View Full Version : KDE desktop blank after login (F12)



carcophan
8th June 2010, 10:02 AM
Hello all,

After a reboot my F12 system, which was working fine, let me login but instead of the KDE desktop I got a blue screen with no task-bar, "start" menu, wallpaper, plasmoids, nothing.

My custom keyboard short-cuts still work (I can get to terminal, dolphin, package kit OK) as do the standard KDE ones (ALT+F2 calls up the "run" window) but I can't seem to work out whats causing the problem.

I've run top but there doesn't seem to be one task hogging the CPU and preventing login completing. I've also tried changing the init level to 3 and back to 5 but that made no difference. Web searching hasn't really helped much.

Can anybody suggest what I can try next?

Thanks in advance

Phil

Skull One
8th June 2010, 10:32 AM
Helllo,
what is your kde version ? Did you update it before the reboot ?
I had the same problem after a kde update, and solved it by removing all the plasma configuration files :


rm ~/.kde/share/config/plasma*

Beware ! this will remove your plasma configuration, and start kde with a default one, so backup the files before !

carcophan
8th June 2010, 10:58 AM
> removing all the plasma configuration files :

Fixed it. Many thanks

<Doffs hat>

[Edit]
After recreating my desktop plasmoids I think the problem was the Qalculate plasmoid. It is probably related to the fact that when I run qalculate_kde it reports

DCOP aborting (delayed) call from 'anonymous-1234' to 'qalculate_kde'

Thanks again

[End edit]

Phil