PDA

View Full Version : Samba permissions



roostertn
4th June 2010, 06:27 PM
I give in.

Been at this for days now.

Cent server 5.4

Samba 3.033-3.28.el5
netatalk-2.0.3-7



Fedora 11 client

samba-client-3.4.7-0.50.fc11.i586


OSX AFP client on 10.6.2/10.5.8


I have to have a shared directory between AFP and SMB.

I had this working on my test server but it refuses to work on my production system.

Files created by AFP users cannot be over written by samba, but I need them to be able to.

All users between both protocols have the same group, call it "afp".

I have ran
chgrp -r afp
chmod -R g+s

on the dierctory.

I can create with both protocols but I can't over write with the samba.
I can over write with the AFP.

When I look in a directory on the server.

ls -l
drwxrws--- 3 user1 afp 4096 Jun 4 11:20 test

Then when looking at the file inside created with AFP:

-rw---S--- 1 user1 afp 9 Jun 4 11:20 test.txt

With samba created, using mask settings in SMB or if its from file directory?

-rwxrw---- 1 user3 afp 0 Jun 4 12:25 test2.txt


I've tried to chmod the directory to 770.

I've tried to 2770.

No luck.

Anyone?