PDA

View Full Version : Unable to update FC12



patanjali
20th May 2010, 03:17 PM
All,

My system (recently installed FC12) is reporting that there are 563 updates available. When I try and install the updates I get to the stage of "Getting list of updates" and receive the message "The package identifier was not well formed". The details are "Package_ID cannot not be parsed". It further says that "This normally indicates an internal error and should be reported."

Does anyone have any knowledge of this error, and how do I go about reporting it.

TIA

p :eek:

giulix
20th May 2010, 03:19 PM
Do a

su -c "yum clean all"

patanjali
20th May 2010, 04:16 PM
Thanks giulix. I'll try that. I presume I run yum update afterwards.

p

CSchwangler
21st May 2010, 07:50 AM
Thats correct, run the following sequence as root

yum clean all
yum update

rfaulkner
22nd May 2010, 05:47 PM
I ran into this problem last week on my build. Here's the thread for that discussion and solution...I did the same thing, updated via CLI and found that later updates were coming properly through the GUI.

http://forums.fedoraforum.org/showthread.php?t=245225
Software Update