PDA

View Full Version : VNCServer: no display configured F12



wildcard442
29th April 2010, 12:59 AM
I am running KDE on F12 and I just installed TigerVNC server. I reconfigured /etc/sysconfig/vncservers as follows:

VNCSSERVERS="1:user1"
VNCSERVERARGS[1]="-geomeetry 800x600"

now when I start vncserver:
# service vncserver start

I get the following:

Starting VNC server: no displays configured

Anyone know what's wrong?

Doug G
29th April 2010, 02:12 AM
You have a spelling error in geometry for one thing, and I'd have to check to know if you need or want to use the dash in front of the argument.

Another guess, is display 1 in use already? Try a different display as a test.

Keldorn
29th April 2010, 07:18 AM
The same trouble here, but it just shows

Starting VNC server: 2:keldorn [FAILED]
The /etc/sysconfig/vncservers looks like

VNCSERVERS="2:keldorn"
VNCSERVERARGS[2]="-geometry 800x600 "
upd: you can use nomachinenx for remote connections - it is very easy to set it up and it has got nice client for windows and linux.

wildcard442
29th April 2010, 02:47 PM
OK, I updated my /etc/sysconfig/vncservers as follows:

VNCSSERVERS="2:user1"
VNCSERVERARGS[2]="geometry 800x600"

also tried:

VNCSSERVERS="2:user1"
VNCSERVERARGS[2]="-geometry 800x600"

and

VNCSSERVERS="2:user1"
VNCSERVERARGS[2]="-geometry 1024x768"


same problem:

Starting VNC server: no displays configured [FAILED]

any ideas?

smr54
29th April 2010, 05:06 PM
Just for fun, see what happens if you remove the geometry part.

wildcard442
29th April 2010, 05:22 PM
same thing:

Starting VNC server: no displays configured [FAILED]

smr54
29th April 2010, 10:32 PM
Grr.

What happens if you comment out the sysconfig stuff and just try running it from command line? Same thing?

Doug G
29th April 2010, 11:33 PM
Anything in your system logs that would help?

wildcard442
30th April 2010, 01:27 AM
how do I run it from the command line? I am using

# service vncserver start

from the command line to get it running... Is there a different way?

Newb question... how do I look at my system logs :D

smr54
30th April 2010, 04:05 AM
Sorry, mental shorthand.

Ok, first service vncserver stop. Make sure it's not running

pgrep Xvnc

That should just bring you back to a command prompt.

Then, as any user--don't have to be root, just type at a command line

vncserver

You'll be told to supply a password, do so. Note that vncserver only reads the first 8 characters, so no point in having a password longer than that.

See what happens. I suspect you'll have the same error, but one never knows.

Keldorn
30th April 2010, 01:32 PM
Anything in your system logs that would help?
There is no logs for vncserver

Ok, first service vncserver stop. Make sure it's not running

pgrep Xvnc

That should just bring you back to a command prompt.

Then, as any user--don't have to be root, just type at a command line

vncserver

You'll be told to supply a password, do so. Note that vncserver only reads the first 8 characters, so no point in having a password longer than that.

See what happens. I suspect you'll have the same error, but one never knows.
it is successfully starts - but don't accept any connections

smr54
30th April 2010, 01:57 PM
Ok, when it starts, it should say what display it is using, Something like

desktop is myhost.mydomain:1

That number after the colon is what you want--:1 is the most typical, meaning that you're on display :0 and so vncserver will use display :1.

Now from another machine, when running vncviewer try to connect with the host and specify that display. For example, you open vncviewer on another machine and when it asks for hostname do

hostname (whatever the hostname or host IP is):1, for example

myhost.mydomain:1

If it's still not accepting connections, then it might be your iptables blocking it. Vnc usually uses ports 5900-6900. You can temporarily turn it off with iptables -F (Note that will completely open your firewall, so if this machine faces the Internet, you might not want to do that--regardless, if you do, just do it for testing, then do

service iptables restart

to put the firewall back in place.

If that turns out to be the issue, you'll have to add a rule--I think that there's a GUI firewall configuration tool, but the name escapes me at the moment.

Keldorn
30th April 2010, 05:41 PM
I forgot to say - the iptables was disabled and it is still don't wotk (As I said before - I have found solution for graphical remote connections - nomachinenx). Now I am just wondering why vncserver don't works as it should.

Doug G
30th April 2010, 07:16 PM
Why not try starting vncserver directly. From a terminal window command line just enter vncserver :2

You should get a message that you'll need to set a password, or if you've done that in the past you should just get a message saying vncserver started. Or if there is an error you should see the error message immediately.

Then assuming you're on the same computer, you can check out vnc with vncviewer localhost:2

Keldorn
30th April 2010, 08:18 PM
Why not try starting vncserver directly. From a terminal window command line just enter vncserver :2

You should get a message that you'll need to set a password, or if you've done that in the past you should just get a message saying vncserver started. Or if there is an error you should see the error message immediately.

Then assuming you're on the same computer, you can check out vnc with vncviewer localhost:2

It works for me. But why I can't use vinagre vnc client for connection?

wildcard442
8th May 2010, 03:52 PM
Why not try starting vncserver directly. From a terminal window command line just enter vncserver :2

You should get a message that you'll need to set a password, or if you've done that in the past you should just get a message saying vncserver started. Or if there is an error you should see the error message immediately.

Then assuming you're on the same computer, you can check out vnc with vncviewer localhost:2

well, that works... but I am still getting the same "cannot start vncserver" error

now, when I use the vncviewer to connect to localhost:1 I get the window, but it is black. there is a cursor, but the window is just black. Any ideas?

Doug G
8th May 2010, 11:43 PM
now, when I use the vncviewer to connect to localhost:1 I get the window, but it is black. there is a cursor, but the window is just black. Any ideas?It used to be you had to edit a file in ~/.vnc to completely enable vnc. I haven't had to do this with fresh fedora 12 installations, but it wouldn't hurt to check. I don't recall the filename, I think it was something like xstart, but it should be obvious.

wildcard442
9th May 2010, 07:07 AM
ya i edited the file

wildcard442
10th May 2010, 08:02 PM
anyone know what the problem is?

DrewP
13th May 2010, 12:38 AM
I'm not sure if you are smarter than me and doing something I don't know about or if you are using TigerVNC the same way you have used previous flavours of VNC and finding it doesn't work.

I documented a set up method that has been very successful for me here: http://forums.fedoraforum.org/showthread.php?p=1262910#post1262910

I haven't visited this forum for a while so only saw your post a few hours ago - otherwise I would have responded sooner.

I hope it helps...

Doug G
13th May 2010, 06:17 AM
I didn't have to do anything special on a recent fedora 12 installation, basically it was:

yum install tigervnc-server
manually start vncserver while logged in as the desired user and add vnc pasword
edit edit the vncserver script for the desired user(s) to start
start the vncserver daemon
open port in firewall
connect right up from another machine on the lan

hmmsjan
13th May 2010, 07:57 AM
I am running KDE on F12 and I just installed TigerVNC server. I reconfigured /etc/sysconfig/vncservers as follows:

VNCSSERVERS="1:user1"
VNCSERVERARGS[1]="-geomeetry 800x600"

now when I start vncserver:
# service vncserver start

I get the following:

Starting VNC server: no displays configured

Anyone know what's wrong?

Hello,

When I look into the /etc/init.d/vncserver script, it loops over the content of the variable VNCSERVERS
In between, it sets a variable SERVS.
If this variable is empty, the "no displays configured" message is printed.
This means, that the VNCSERVERS variable is empty. When I look to your config, there is
VNCSSERVERS with one "S" too much.
Is this typo causing this problem?

In addition, you should be sure that the user exists and has a vnc password, to be entered with
vncpasswd, and ~/.vnc/xstartup starts some session on the VNC server.

Good luck!

DrewP
13th May 2010, 08:41 AM
edit the vncserver script for the desired user(s) to start
start the vncserver daemon
open port in firewall

If that is all the functionality you need then that is an ideal solution - but you may as well have just enabled vino instead of installing TigerVNC


edit the vncserver script for the desired user(s) to start
TigerVNC allows you to see the X Login screen. You can take control of the computer BEFORE anyone has logged in, but your session will control the display shown on the monitor attached to that PC. It's analogous to the difference between running VNCserver as a user application and as a service in Windows Land.

Caveat: Must have a working network of course so Wifi-connected PCs will remain invisible until someone logs in and establishes a network connection


open port in firewall
In a purely Linux environment you don't need to open port 5900. You can avoid the potential security issues of having an open, well known port with the well known security limitation of having a maximum password length of 8 characters.

Tiger VNC simplifies the use of tunnelling so you don't need to remember the arcane command required to set up the tunnel and which in many cases is probably considered just too much effort for the benefit it brings.
You still have to open port 22 on the host PC (but I assume you would do that anyway for all the other management tricks you can use) and there is plenty of guidance on the web for making this open port as secure as possible.
The immediate benefit is that you can choose which accounts can connect through ssh and ensure they have non-trivial names and passwords.