View Full Version : Installing HP Deskjet F4480 Printer

25th April 2010, 07:23 PM
I am trying to install a HP Deskjet F4480 All in one printer and am having no success. I am running Fedora Core 12 and have installed every possible package that I can find or have read about on these forums and my system still doesn't detect or allow me to install this printer. I have tried to install through cups and also using the HP Device manager with no success. Nothing I do makes a difference. I have tried using different drivers, again with no success and I can't find a driver specific for a F4480 and that includes a search on the HP website. I have installed the latest hplip, hplip-gui, foomatic, cups, etc. I don't know what else to do. The last time I had to install a printer was I believe, on Fedora core 3 and I used the ptal-init setup command. Any help would be greatly appreciated as I just bought this printer and told my skeptical spouse not to worry as HP plays very nice with Linux....I may be in trouble on that one. I have also checked my connections between the printer and the USB port (port was detected by 12) and also that the printer was on and ready to print.

25th April 2010, 07:52 PM
Hello hoppy72,

According to the supported printers list at HP, that printer has full support from hplip. Also according to HP, once you have installed hplip you can use hp-setup or CUPS or the Fedora printer applet to set up the printer. Now, I don't have that printer. But I use only HP printers, and I have found that the printer model is always in the list of printers in those various installation applets if I have installed hplip. One old HP printer not supported by hplip has to use foomatic, but the same thing happens at setup time for it. I use the Fedora printers applet to set up my printers, but I've also used hp-setup and the CUPS thingy, too. So what exactly have you been doing to attempt to set up this printer?

25th April 2010, 08:37 PM
I thank you for the quick response. I have first went to System-Administration-printing and attempted to install it that way. It does not find my printer and then I can choose either Lpt #1 or Serial #1 with no usb choice listed. I tried both the serial port and the Lpt port. it brings up a long list of printer manufacturers and I, of course, pick HP and my driver is not listed there anywhere. I tried using the driver for the Deskjet 4400 series and also the 4100 series with no luck. I then went to the CUPs website and then to adminstration and then adding printers and classes and again, my printer is not listed. i finally tried using the HP Device manager from System - Administration and neither finds my printer nor does it list my printer. I have checked and I have the hplip and the hplip-gui both installed and cups is also installed as well as foomatic. I have also used nothing but HP printers and this is the first time I have had any problems installing. My printer is not showing up on any lists that accompanies either the HP Device Manager, the Cups website or the printing software that accompanies Fedora 12.