PDA

View Full Version : compiz screen refresh problem



mopodo
24th April 2010, 03:25 PM
HI

I recently switched from Debian to Fedora (F12 64Bit).
Most things works as expected, but I have still some problems.

I installed kmod-nvidia and blacklisted nouveau.

I enabled compiz on my gnome desktop with wobbly windows, desktop cube, blurring and some simple effects.
In the preferences «Desktop Effects» is set to standard, I start compiz via «Startup Applications».

My problem is if compiz is enabled my screen sometimes doesn't update some changed parts of it. Looks like a X problem.
As example I close a tab in firefox, but some parts of the window still show the page from the closed tab, when I hover with the mouse they get updated.
Other applications like gnome-terminal, exaile and amarok are also affected.

Can someone help me fix this annoying problem?

My setup
Up to date F12 64bit, running gnome
Nvidia 9800 GTX card

mightymouse2045
22nd December 2010, 01:12 PM
did you ever get a fix for this because i am having the same problem on Fedora 14

Doug Hutcheson
10th March 2011, 04:58 AM
Ditto on FC14 x86_64 / Lenovo T61 notebook / Gnome desktop / nvidia-graphics.x86_64 : NVIDIA Linux Display Driver.

The only solution I have found is to turn off desktop effects (System/Preferences/Desktop Effects/Standard), but this disables one function in the Simon voice control application (http://simon-listens.org/), which depends on a compositing window manager to display a mouse control grid.

With compiz active, editing a document in OpenOffice.org Writer became an unpleasant challenge and many other apps were also affected.

---------- Post added at 01:58 PM ---------- Previous post was at 01:32 PM ----------

On further investigation, I found this (http://en.gentoo-wiki.com/wiki/Compiz-Fusion#Refresh_Problem_for_Nvidia_Users) post. By following the instruction to edit /usr/bin/compiz-manager, I have solved the problem - at least, all the tests I have tried have worked OK. Editing in Writer is no longer a chore and refreshing scrolled lists has started to work properly.

I hope it works for you.

Doug Hutcheson
12th March 2011, 05:38 AM
I spoke too soon.

The above fix seemed to work fine the first time I tried it, but behaviour has reverted to the old problem of spotty refresh in some windows and OpenOffice.org Writer has problems refreshing the window when editing is at the end of one line or the beginning of the next.

I have switched compiz off now, to get stable graphics refresh.

"8-(
Doug

---------- Post added at 02:38 PM ---------- Previous post was at 12:44 PM ----------

What seems to work - for me - is:
open System/Preferences/compiz config settings manager,
scroll down to Utilities
enable the module 'Workarounds'.

Having done that, all my problems have gone away (well, all my problems with compiz anyway).

Cheers,
Doug