View Full Version : yum upgrade to F14 successful

18th April 2010, 04:40 AM
d/l fedora-release-14-0.4.noarch from raw hide
rpm -Uvh fedora-release....rpm --test
rpm -Uvh fedora-release....rpm

Yum upgrade yum rpm yum-utils kernel-PAE kernel-PAE-devel kernel-headers perf python glibc

If yum stops due to DeviceKit conflicts with upower then
rpm -e DeviceKit --nodeps
#start again
yum upgrade

#when complete

$ rpm -q fedora-release
$ uname -a
Linux Jovette-14.WinProxy 2.6.34-0.28.rc3.git3.fc14.i686.PAE #1 SMP Mon Apr 5 17:05:06 UTC 2010 i686 i686 i386 GNU/Linux


20th April 2010, 05:17 AM
Upgraded Pent IV intel865 Intel EG2

sealert seems to be on or off depending on the version of some other support packages, very annoying. Packages that deps of selinux packages s/b taking that into account. If not it can leave the whole system unusable for days, weeks at a time.

Running with kernel-2.6.34-0.38.rc5.git0.fc14.i686.PAE


22nd April 2010, 06:28 AM
I have just one question:
I have F13 on a test partition, and it work with nvidia drivers.
I would like test F14, but I see here that nvidia drivers don't work with 2.6.34 kernel:
http://forums.fedoraforum.org/showthread.php?t=239527&page=2 post #18.
Can I remove nvidia drivers first or wait for an update working with 2.6.34 kernel?

22nd April 2010, 04:01 PM
Ditto...upgraded from FC 13 BETA to Rawhide.

System is running under VMWare Fusion on a MacBook Pro:

uname -r -v shows 2.6.34-0.38.rc5.git0.fc14.i686.PAE #1 SMP Tue Apr 20 01:57:19 UTC 2010

Upgraded using the command-line:

1. Type: yum install fedora-release-rawhide
2. Then type: yum --disablerepo=* --enablerepo=rawhide update

Archived/Removed the repos for FC 13 BETA; and, configured the following as per the instructions from:

---You may want to enable/disable repositories in /etc/yum.repos.d/ so that only the "Fedora Development" repository is enabled. This will allow daily Rawhide updates to appear by default in desktop notifications and "yum update".---

Rawhide, at least under Fusion, seems to work a bit smoother than FC 13 Beta.

Also configured vmware-tools with no issues.

24th April 2010, 05:00 AM
When I converted, it was right after the change to a non frozen rawhide. I used yum install fedora-release-14, then logged out of user, went into init 3, then did a yum upgrade. You actually didn't have to use "--disablerepo=* --enablerepo=rawhide" because installing fedora-release should have enabled/disabled the correct repos for you.

13th May 2010, 03:31 PM
So if I do this, do I lose the use of my other repos? The ones that don't have F14 stuff yet? I'd like to have mplayer etc. I'd like to take the plunge. Kurt

13th May 2010, 04:03 PM
Hello kurtdriver,

I took a f13 install, set it up the way I wanted it and updated it. I Then used basically the same method as slowjet to take it to f14. I still can use mplayer ect. without issue but there are some packages with dependency issues that I have been skipping.

[kyryder@localhost ~]$ rpm -qa|grep mplayer

I have been using --skip-broken when updating and have not tried to fix any of the dependency issues yet but everything I have used is working. :)

Hope this Helps,


13th May 2010, 04:16 PM
Thanks Ky, I'm doing it tonight.

13th May 2010, 04:20 PM
Here is a list of the dependency problems from my last update today:

Skipped (dependency problems):
Packages skipped because of dependency problems:
bitstream-vera-fonts-common-1.10-18.fc12.noarch from rawhide
bitstream-vera-sans-fonts-1.10-18.fc12.noarch from rawhide
bitstream-vera-sans-mono-fonts-1.10-18.fc12.noarch from rawhide
ffmpeg-libs-0.6-0.3.20100429svn.fc14.i686 from rpmfusion-free-rawhide
ftgl-2.1.3-0.3.rc5.fc13.i686 from rawhide
glew-1.5.2-2.fc13.i686 from rawhide
kde-filesystem-4-35.fc13.noarch from rawhide
libprojectM-2.0.1-4.fc14.i686 from rawhide
libproxy-0.4.0-1.fc14.i686 from rawhide
libproxy-bin-0.4.0-1.fc14.i686 from rawhide
libproxy-python-0.4.0-1.fc14.i686 from rawhide
libquicktime-1.1.5-1.fc14.i686 from rpmfusion-free-rawhide
libsoup-2.30.1-1.fc14.i686 from rawhide
libsoup-devel-2.30.1-1.fc14.i686 from rawhide
mencoder-1.0-0.117.20100429svn.fc14.i686 from rpmfusion-free-rawhide
mplayer-1.0-0.117.20100429svn.fc14.i686 from rpmfusion-free-rawhide
mplayer-common-1.0-0.117.20100429svn.fc14.i686 from rpmfusion-free-rawhide
neon-0.29.3-1.fc14.i686 from rawhide
vlc-1.1.0-0.6.pre3.fc14.i686 from rpmfusion-free-rawhide
vlc-core-1.1.0-0.6.pre3.fc14.i686 from rpmfusion-free-rawhide
x264-libs-0.0.0-0.27.20100429gitd9db8b3.fc14.i686 from rpmfusion-free-rawhide

I have made no effort to fix these things just thought I give you a heads up on the list a packages that will not update for me without more effort.


13th May 2010, 06:04 PM
I got the package from pbone and it had dependancies

[root@Jupiter kurt]# rpm -Uvh Desktop/fedora-release-14-0.4.noarch.rpm
error: Failed dependencies:
fedora-release-rawhide = 14-0.4 is needed by fedora-release-14-0.4.noarc

but the package doesn't exist according to yum.
[root@Jupiter kurt]# yum install fedora-release-rawhide-14-0.4
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
No package fedora-release-rawhide-14-0.4 available.
Nothing to do

Where do I get these packages? I'm missing something really straightforward I suspect.
One other question, this is the branch that leads to fedora 14, yes? Thanks, Kurt

13th May 2010, 06:09 PM
There where two packages that I used:
fedora-release-14-0.4.noarch.rpm , fedora-release-rawhide-14-0.4.noarch.rpm
If I remember right they where both on the same page at koji.fedoraproject.org .



WARNING: This is not a stable version and I can guarantee there will be many,many, issues.

That being said here is the link: http://koji.fedoraproject.org/koji/buildinfo?buildID=159713

13th May 2010, 06:30 PM
I get this. Can I just uninstall the two F13-1s?

[root@Jupiter Desktop]# rpm -Uvh fedora-release-14-0.4.noarch.rpm
error: Failed dependencies:
fedora-release-rawhide = 14-0.4 is needed by fedora-release-14-0.4.noarch
fedora-release = 13-1 is needed by (installed) fedora-release-rawhide-13-1.noarch

Thanks for your help.

13th May 2010, 07:05 PM
Do you have rpmfusion-free-rawhide and rpmfusion-nonfree-rawhide active? Just a quick look and I can see mplayer and vlc. You need rpmfusion enabled for those.

13th May 2010, 08:14 PM
No I don't. Are there other repos that must be enabled?

13th May 2010, 08:20 PM
I get this. Can I just uninstall the two F13-1s?

[root@Jupiter Desktop]# rpm -Uvh fedora-release-14-0.4.noarch.rpm
error: Failed dependencies:
fedora-release-rawhide = 14-0.4 is needed by fedora-release-14-0.4.noarch
fedora-release = 13-1 is needed by (installed) fedora-release-rawhide-13-1.noarch

Thanks for your help.

Not trying to be rude or anything but if you can't figure out how to install the two packages on your own, you probably should not be attempting to run rawhide since there will be many times you will have to do things like this just to keep things running.

If you still want to try to continue, try installing both packages with one rpm command.

rpm -Uvh fedora-release-14-0.4.noarch.rpm fedora-release-rawhide-14-0.4.noarch.rpm


13th May 2010, 08:29 PM
Rpm failed in part because of the presence of the two for F13. When I ran
rpm -e fedora-release-rawhide-13-1 I got error messages about other dependancies, including init or inittab (I don't recall which), So I still have the same question, can I just remove the F13 ones and then install the ones for F14?

13th May 2010, 09:00 PM
You can set up rpmfusion repos for rawhide from this link. If you have rpmfusion repos from F13, make sure they're disabled.


18th May 2010, 05:54 AM
Congratulate me as well - updated from 13.
Through the yum, there was not errors at all.
I have some question, but it later.
Question - is there a online chat about Rawhide?


18th May 2010, 03:06 PM

#fedora-qa irc channel might be appropriate

18th May 2010, 03:06 PM

#fedora-qa irc channel might be appropriate