PDA

View Full Version : ONTIMEOUT issue in isolinux.cfg using vesamenu.cfg



sneve
15th April 2010, 04:15 PM
Hi,

I have customized fedora 12 installation using revisor. The installer gives options based on the hard disk sizes available on a new system and partitions the system appropriately. The installer works fine otherwise, however I have a problem with the ontimeout in the isolinux.cfg. Here is my isolinux.cfg file -

default vesamenu.c32
#prompt 1
timeout 600
ontimeout linux

menu title Welcome to OS Installation for INSTAPP!
menu color border 0 #ffffffff #00000000
menu color sel 7 #ffffffff #ff000000
menu color title 0 #ffffffff #00000000
menu color tabmsg 0 #ffffffff #00000000
menu color unsel 0 #ffffffff #00000000
menu color hotsel 0 #ff000000 #ffffffff
menu color hotkey 7 #ffffffff #ff000000
menu color scrollbar 0 #ffffffff #00000000

label linux
menu label ^Install on INSTAPP-one (3 X 160G HDD - RAID5)
menu default
kernel vmlinuz
append initrd=initrd.img ks=cdrom:/APP-One/ks.cfg ramdisk_size=8192
label LS-two
menu label Install on INSTAPP-^two (6 X 750G HDD-6/8G RAM)
kernel vmlinuz
append initrd=initrd.img ks=cdrom:/APP-Two/ks.cfg ramdisk_size=8192
label Demo
menu label Install on ^Demo System (2 X 80G HDD)
kernel vmlinuz
append initrd=initrd.img ks=cdrom:/APP-Demo/ks.cfg ramdisk_size=8192
label local
menu label Abort this installation and boot from ^local drive
localboot 0xffff
label rescue
menu label ^Rescue installed system
kernel vmlinuz
append initrd=initrd.img rescue
label memtest86
menu label ^Memory test
kernel memtest
append -

The installation menu is displayed perfectly and I am able to install using all the options by highlighting the option and hitting enter.

However, if I let it timeout without providing input, it gives the following error:

isolinux: Disk error 01, AX = 4200, drive 02
Boot failed: press a key to retry...

Must be something stupid I am doing, but am not able to figure out what...

Please help!

Thanks in advance,
Sanjeev