PDA

View Full Version : Transaction Check error:- YUM update fails



BobNutfield
15th April 2010, 12:42 PM
Hello Everyone

I just install F13 to my old laptop and while it is very buggy as I expected, things are going OK. However,
after downloading 382 MB of updates, it fails to update with a transaction check error:


Transaction Check Error:
file /usr/lib/girepository-1.0/GUPnP-1.0.typelib from install of gupnp-0.13.3-4.fc13.i686 conflicts with file from package gir-repository-0.6.5-6.fc13.i686


I did yum clean all and downloaded them again, just to get the same error.

Anyone know how I can resolve this?

Any help appreciated.

Bob

---------- Post added at 12:42 PM CDT ---------- Previous post was at 12:36 PM CDT ----------

Sorry, just found another thread with a workaround.

Apologize for not checking deep enough before posting.

Bob

SlowJet
15th April 2010, 01:38 PM
package gir-repository needs to be updated with the rpm from koji first.

SJ

BobNutfield
15th April 2010, 02:01 PM
package gir-repository needs to be updated with the rpm from koji first.

SJ

Thank you. Could you tell me how to do that? I do not find that repo in the list, which is probably the problem.

Thanks

Bob

SlowJet
15th April 2010, 02:13 PM
http://koji.fedoraproject.org/koji/builds?prefix=g&order=-completion_time
D/L the rpm and update it.

su -
rpm -Uvh gir-repository.n.n-n.f13.arch.rpm --test
if no errors then remove --test and repeat.
rpm -Uvh gir-repository.n.n-n.f13.arch.rpm

Then try
yum clean metadata
yum check-update
to see if the updates list correctly.
If they do then
yum update

SJ

BobNutfield
15th April 2010, 06:38 PM
http://koji.fedoraproject.org/koji/builds?prefix=g&order=-completion_time
D/L the rpm and update it.

su -
rpm -Uvh gir-repository.n.n-n.f13.arch.rpm --test
if no errors then remove --test and repeat.
rpm -Uvh gir-repository.n.n-n.f13.arch.rpm

Then try
yum clean metadata
yum check-update
to see if the updates list correctly.
If they do then
yum update

SJ

Thank you very much. That solved it. No problems with update now.

Bob

CiaW
16th April 2010, 02:29 AM
I just went to the koji page to dl the rpms, and the only gir-repository and gupnp files on there are for FC14.

There's a link to a bugzilla report on this thread (http://forums.fedoraforum.org/showthread.php?t=243780), but it's not entirely clear whether it'll actually get fixed in F13 ? I'm confused... in the meantime I use yumex to update and just un-select that package and update everything else. After I also unselect the rpmfusion repo's because they're having mirror issues, apparently?

ronaldo.viera
16th April 2010, 02:20 PM
Hey CiaW try this package http://koji.fedoraproject.org/koji/buildinfo?buildID=166784 There are i686 and x86_64 versions, choose the appropriated for your system and follow the steps from SlowJet post. It worked in Fedora 13 beta version.

CiaW
16th April 2010, 05:20 PM
Hey CiaW try this package http://koji.fedoraproject.org/koji/buildinfo?buildID=166784 There are i686 and x86_64 versions, choose the appropriated for your system and follow the steps from SlowJet post. It worked in Fedora 13 beta version.

And, that worked! Now fully updated. Thanks mucho. :)

AdamW
16th April 2010, 07:01 PM
"I just install F13 to my old laptop and while it is very buggy as I expected"

We don't actually expect it to be very buggy, at this point. Can you expand a bit? Thanks!