PDA

View Full Version : problem installing fedora 13 alpha, maybe bug in the installer



_lorenzo87_
4th April 2010, 07:03 PM
hi, i've just made a try to get fedora 13 alpha on my macbook intel (x86_64 live cds, both kde and gnome one) and during the setup I got stuck on a thing:

selecting the option of a custom partitioning layout I decided to make a root partition ad a swap partition, mac uses GPT table so it uses an efi partition for managing os boot.. after making the partition as i always do i pressed the "next" buton and a popup warned me that /dev/sda need to have a disk label.... is it a problem with something new in anaconda??

sorry for my bad english, if i was unclear i can try to explain me better

waiting to see if it will be fixed on beta, if not can someone explain me where to send bugs on rawhide?

AdamW
6th April 2010, 09:04 PM
F13 is not Rawhide, the two are different under the new process. If there's actually a bug here (I don't quite understand your explanation), file it against 'anaconda' with Fedora version '13' (13 is already available as a choice to file bugs against).

_lorenzo87_
7th April 2010, 03:36 PM
thanks for the reply adam, just made a bug report.. Sorry for my unclear explanation, the problem is related only to anaconda. When i try to install f13 alpha or a f13 nighly build i get an error during the partitioning phase, macs don't use a "normal" partitioning system with primary and extended partitions, they use a GPT system with only primary partitions, less limited number of partitions and a different system for managing partitions.. after partitioning as i always done anaconda stopped the installation finding that my hard disk had not an MSDOS disk label (normal for a GPT system but not for a "normal" hard disk) so i can't procede installing the os.. hope that i was a little more clear :) i just got a good answer from bugzilla so it's all ok now

AdamW
7th April 2010, 05:53 PM
OK, great. Thanks :)