PDA

View Full Version : [rpmbuilding] - Installed (but unpackaged) file(s) found:



mouse_runner
25th March 2010, 07:26 PM
i have tried to build an rpm, but i get an error:

error: Installed (but unpackaged) file(s) found:
/usr/share/locale/ar/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/az/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/bg/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ca/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/cs/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/da/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/de/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/dz/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/el/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/en_CA/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/en_GB/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/es/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/eu/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/fi/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/fr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/gl/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/gu/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/hi/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/hr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/hu/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/it/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ja/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ko/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/lt/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ml/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/mr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/nb/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ne/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/nl/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/nn/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/oc/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/pa/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/pl/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/pt/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/pt_BR/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ru/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/rw/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sk/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sl/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sq/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sr@Latn/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sv/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/tr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/uk/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/vi/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/zh_CN/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/zh_TW/LC_MESSAGES/gimp20-gap.mo


RPM build errors:
Installed (but unpackaged) file(s) found:
/usr/share/locale/ar/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/az/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/bg/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ca/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/cs/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/da/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/de/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/dz/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/el/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/en_CA/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/en_GB/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/es/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/eu/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/fi/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/fr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/gl/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/gu/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/hi/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/hr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/hu/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/it/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ja/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ko/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/lt/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ml/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/mr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/nb/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ne/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/nl/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/nn/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/oc/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/pa/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/pl/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/pt/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/pt_BR/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/ru/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/rw/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sk/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sl/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sq/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sr@Latn/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/sv/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/tr/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/uk/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/vi/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/zh_CN/LC_MESSAGES/gimp20-gap.mo
/usr/share/locale/zh_TW/LC_MESSAGES/gimp20-gap.mo

i have been to: http://forums.fedoraforum.org/printthread.php?t=178924
but that does not covers my issue

thanks

---------- Post added at 07:26 PM CDT ---------- Previous post was at 07:04 PM CDT ----------

i have found this

http://fedoraproject.org/wiki/Docs/Drafts/BuildingPackagesGuide
some sections below are my issues

still figuring out what to do.........

PabloTwo
25th March 2010, 08:19 PM
To handle language support files, you need in your "%install" section, this line:

%find_lang %{name}

And your "%files" section to have this statement:

%files -f %{name}.lang

---------- Post added at 03:19 PM CDT ---------- Previous post was at 03:05 PM CDT ----------

You might also want to have a long look at this gimp spec file (http://cvs.fedoraproject.org/viewvc/rpms/gimp/F-12/gimp.spec?revision=1.200&view=markup) to get an idea how you might have to do this with the gimp source code.